Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   High Oil Pressure (http://www.wranglerforum.com/f210/high-oil-pressure-8349.html)

hecace 05-27-2007 07:36 PM

High Oil Pressure
 
Hi, All

Happy Memorial's Day!

We just changed the oil pump on our 97 TJ and now it reads around 40 when idle and 80 (tops off) when accelerating. Anything I shoudl be concerned about or is this normal?

Thanks:confused:

AzTJ 05-27-2007 07:51 PM

40 at idle is norm... but hitting 80, i'd be worried about spinning a rod bearing or something. did you replace the pressure sending unit as well? might be giving false readings.

hecace 05-27-2007 08:18 PM

Thanks for the reply. I

know they changed the oil pressure sensor initially and that didn't fix the issue - which was that the oil pressure would drop to zero at idle. The shop then replaced the oil pump and here we are...

AzTJ 05-27-2007 08:24 PM

My TJ did this once, just randomly, and hasn't had an issue with it since. It would jump between 30-50 which isn't bad. ANd my moms XJ does this occationally, but usually only after a trip to a lower altitude and back up.... but it usually doesn't last more than a day or two.

I wouldn't worry too much, unless its constantly at 80.

hecace 05-27-2007 08:39 PM

We'll keep and eye on it...so far it reaches 80 when it accelerates, the back down when decelerating. We had several things changed all at once and we just noticed this change.

Thanks for your help on this.

AzTJ 05-27-2007 08:42 PM

Not a prob - but one thing - when you say accelerating, are you hitting the throttle hard or just average?

hecace 05-27-2007 08:46 PM

Not hard. The TJ has a 4 cyl engine so as we are driving around and RPM's climb, so does the oil gauge; when we slow down it drops accordingly.

AzTJ 05-27-2007 08:58 PM

I'd just keep an eye on it and listen for irregular noises... but it should be fine.

hecace 05-27-2007 09:03 PM

We'll do. Should be able to hear any differences now. We just replaced the catalytic converter and 80% of the rattling is now gone...

Thanks much for your feedback. We have had the TJ for about 2 months and we love it. Just need to know what's what. This is a great forum for it.

AzTJ 05-27-2007 09:04 PM

Sure thing :D

Mudweiser 05-28-2007 10:18 AM

Not sure if this will help ya, but ill tell you a problem i had which was my first encounter with oil pressure the jeep. After a Deep hole mud bog one weekend, my oil pressure would run normal at driving speeds, and fall to 0 when idling. Figured i must of killed the sending unit..or i ingested more mud then i figured and got the oil pump. Pulled plugs cleaned the block etc, and stepped through all the hoops. Bout a week later my oil pressure would read 100psi(maxed on gauge) at start up...then as she warmed up..would gradually fall to normal. I figred it was the gauge and ignored it. One morning i cranked it up leaving work, and i hear liquid hittin the ground. Look under the Jeep to find bout 6 quarts of oil on the ground. Bout this time im thinking "Guess that 350 conversion is closer then i thought". Turns out after some investigation, my pressure was so high, the oil filter blew the gaskets around it slam off and was rainbow shooting oil everywhere. 3 more oil changes, sea foam, more sea foam, engine flush, and a new oil pump. She runs better then ever. Turns out the culprit was the bypass vavle in the oil pump itself. a single grain of sand had gotten in the crank case, and clogged up the valve. Price i pay for making a submarine out of a jeep i guess. >..<


All times are GMT -5. The time now is 05:33 AM.