Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   speedo gears going nuts (http://www.wranglerforum.com/f282/speedo-gears-going-nuts-83791.html)

jeepskala 03-08-2011 09:32 PM

speedo gears going nuts
 
ok i have two jeeps... a blue 97, with 410 gears, and a green 97 with 307 gears.

i swapped the axles over, so now the blue one have 307s and the green has 410s.

i went to go swap the speedo gear. what do you know. the plugs are different... so then i look on here find out that the gears remove out of the sensor.

finaly getting the sensor and gear out of the green truck(the gear ment for 307) realise the gear is not staying in the sensor... either way i take it out. and go to put it in the blue jeep that now has the 307s. gear clicks in bolt it on. speedo does not work...

go to the the gear (meant for 410s) in the green jeep. i cannot get the sensor to go in strieght...

WTF>>>>>

so i said F%$k it and put the speedo gears back into the trucks they came from even tho they are not set up for the new ratios..

the blue jeep with 307s that has a speedo gear for 410s work just not accurate as before. BUT!! the green jeep that now has the 410 gears but has the speed gear for a 307 does not work. it is in strieght, and all the way, and now engine light is on for speed gear..

ARG:banghead::banghead::banghead::banghead::banghe ad::banghead:

jeepskala 03-08-2011 10:12 PM

if it helps the green jeep that now has 4.10 gears also has a SYE

Wesboy 03-09-2011 02:38 AM

Each speedo gear housing can be re-installed 4 different ways. If it isn't reinstalled the right way, the speedo will not work.
There are numbers on the plastic housing relating to number of speedo gear teeth, the relevant numbers are supposed to line up with a notch on the transfer case.

Well, I couldn't find what I had to line it up with so I re-installed the housing in each of 4positions until the speedo worked.

jeepskala 03-09-2011 06:52 AM

ok that helps... now, also if i change the speed gear i have to change the positition of the sensor

h2obill 03-09-2011 07:22 AM

some quick info here Changing Your Jeep Speedometer Gear

http://www.4x4xplor.com/images/speedo/speedo07.jpg

jeepskala 03-09-2011 07:20 PM

ok i did all the obove. i got the blue jeep done and works A OkAY now i did the same thing on the green one. still nothing. the engine light is on the speed gear. and i did everything right and still no luck?? does anyone know the eletrical end of this?

Jerry Bransford 03-09-2011 07:24 PM

When that happens, it is usually nothing more than the speedometer gear housing just needs to be rotated a tad more so the speedometer gear can engage the pinion gear underneath.

jeepskala 03-09-2011 07:35 PM

Quote:

Originally Posted by jeepskala (Post 1107784)
ok i did all the obove. i got the blue jeep done and works A OkAY now i did the same thing on the green one. still nothing. the engine light is on the speed gear. and i did everything right and still no luck?? does anyone know the eletrical end of this?


well it looks like its the wrong sensor also... someone before me deff changed the sensors and sliced the wires.

i put the gear in the sensor, and put a drill to the gear spun it fast, and the speedomiter did not move. so i found out the sensor is the same on as on a ZJ and my buddy is scrapping his zj so ill take his sensor and wire pig tail and try that.. any other sugestions?


All times are GMT -5. The time now is 10:01 AM.