Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   high idle / missing... helppppp plz (http://www.wranglerforum.com/f282/high-idle-missing-helppppp-plz-83915.html)

scgeek12 03-09-2011 03:55 PM

high idle / missing... helppppp plz
 
99 tj 6cyl 4.0

ok i know there are quite a few threads on here about the high idle problem and i have researched them and tried everything ive found so far, here are my symptoms- (sorry its long, trying to be as descriptive as possible)

a few days ago the idle started to jump up and down a bit, i took the IAC apart, and took the throttle body out and cleaned it all, cleaned the IAC, put it all back together and it started to idle perfectly, for about 2 days..

2 days ago it started to stay around 1000-1200 rpms when i was slowing down to a stop even with the clutch in, as soon as i stoped though it would go right down to 500 and idle perfect, this didnt bother me that much but yesterday while i was driving to work i got it out on the highway and it "missed" i am not 100% that is what it did but it felt like it missed, or hessitated, and the instant it did that the check engine light came on, it continuted to "miss" randomly the whole way to work, but the idle went back to normal after it did this???

brought it to autozone this morning and had them read the codes, 2 TPS codes and 1 MAP code, i bought both and replaced them, it made the "missing" MUCH worse, so i took them both out and returned them, put the old ones back in and it went back to how it was (missing but not as much)..

on the way home from returning the sensors my high idle came back WITH the missing, but now it is not going away when i stop, it just sits around 1200-2000 rpms i took the distributor cap off and there was a bit of dry mud in there and they looked corroded so i went and bought a new cap / rotor and 6 new spark plugs, put them in and no change, still idling very high and missing, i after i did this i tried unplugging the sensors 1 at a time, if i unplug the MAP the idle starts to "loop", if i unplug the TPS the idle goes right down to 500, which is perfect?? i have the TPS unplugged right now and it is idling fine, have not tried to drive it yet so not sure if it is missing

*****ALSO***** the cruise control was working perfect untill it "missed" the first time now the light on the dash comes on saying "cruise" but it will not work.......

please let me know what other info is needed to diagnose, or anything to try im at a loss...

scgeek12 03-09-2011 04:59 PM

*****edit****
 
just drove it around with the TPS unplugged, idles fine but still missing... i bought a new borg warner tps, the last tps and map i bought were crap duralast ones.. maybe bad from autozone?

rrich 03-09-2011 05:04 PM

I think you'll find it's undriveable with the TPS disconnected.

Am I to presume you disconnected the battery for at least 8 hours after you changed sensors? The poor ECM is getting confused with all the sensor swapping. Do it again - at least 8 hours - reconnect the TPS BEFORE you reconnect the battery.

That may have been the cure all along.

Autozone sensors? When will they ever learn - they are often worse than the original defective ones.

If after the 8 hour trick it still acts up, check the grounds - use a battery jumper cable from battery (-) to body ground. If that helps, just run a new ground strap - it could take hours, days, weeks, months to find the defective ground.

scgeek12 03-09-2011 05:19 PM

ok just put the new borg warner TPS in and it went right back to the high idle / miss, i did not know to leave the battery unhooked for atleast hours, i will go unhook it, i have to leave for work in 40minutes anyway so will hook it all back up in the morning and let you know how it turns out, thanks!

***EDIT***
dont want to sound like to much of a dumb*** but the negative wire goin to the batter was loose as hell and able to come off by hand, i will put a new negative wire on 2morrow

scgeek12 03-10-2011 12:58 PM

plugged the battery back up this morning and took it out for a drive, runs perfect!! no more check engine light, cruise control works again, idling perfect and no more "missing" which i found out was actually a hesitation, not a miss., thanks for the awsome reply, good fix!


All times are GMT -5. The time now is 06:50 PM.