Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   YJ with bad idle and rough running (http://www.wranglerforum.com/f218/yj-with-bad-idle-and-rough-running-8948.html)

erickpl 06-21-2007 01:32 PM

YJ with bad idle and rough running
 
A friend/neighbor of mine has a YJ with the 2.5L engine and he is having a hard time getting it to run smooth. He has replaced plugs, wires, distributor/cap, etc and it still doesn't play nice. He swapped out the fuel filter and put a new one in. It ran nice for about 3 days he said then went back to the back idling/rough running.

I'm thinking he has junk in the tank and may possibly need to drop and clean or replace it and/or the fuel pump. I'm not sure how different the YJ and TJ are in terms of tank and pump, so any pointers, advice, tips would be appreciated.

Once he gets this thing running, he wants to go wheel with our group. If he can't get it working, he'll likely sell it and look for a TJ to build up.

Grandpa Jeeper 06-21-2007 07:03 PM

At what point in his tank of gas is this happening? Right after he fills it up or after 150-200 miles of driving? I'd have him put about 4 oz of pure acetone in it for 2-3 tanks and see what happens. He should see it clear up within that time/use frame.

erickpl 06-22-2007 09:09 AM

I'll have to check with him on that. He was out last night and I didn't get a chance to talk to him.

skeeter 06-22-2007 09:24 AM

Open the fuel filter and see if it's getting plugged up.
Also check for vacuum leaks.


All times are GMT -5. The time now is 04:01 PM.