Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   front axel issue dana 30 (http://www.wranglerforum.com/f19/front-axel-issue-dana-30-a-9052.html)

93 wrangler 06-25-2007 09:19 PM

front axel issue dana 30
 
well got the title from douce bag saturday so i decided to start work, the front passenger axel was pukeing gear lube so i tore it all down and replaced the seal that is located in behind the accuator for the 4wd drove it about 15 miles on the street yesterday and had no more leak, today took it out in the woods for the first time hopeing to make a bond with the new wrangler lol got home and check out the axel to make sure it was dry and to my surprise ther was gear lube all over the tire, same seal started to leak. just got it all ripped back apart so now my question is there are 3 seals in the axel 2 inners and one outer for the non disconnect type it has the 2 piece axel on the pass side so why is it still leaking? is it do to the 2 iners i didnt replace? i know it was stupid not to since they where right there in all and by the way this is a 93 wrangler with a dana 30 non disconnect.

jeeperman 06-25-2007 10:47 PM

Is there any scoring on the axle shaft, if so, it may be eating seals, or just not sealing in the first place. I would check that before I installed the new seals.

Absolute Offroad 06-25-2007 10:55 PM

Quote:

Originally Posted by 93 wrangler (Post 96414)
well got the title from douce bag saturday so i decided to start work, the front passenger axel was pukeing gear lube so i tore it all down and replaced the seal that is located in behind the accuator for the 4wd drove it about 15 miles on the street yesterday and had no more leak, today took it out in the woods for the first time hopeing to make a bond with the new wrangler lol got home and check out the axel to make sure it was dry and to my surprise ther was gear lube all over the tire, same seal started to leak. just got it all ripped back apart so now my question is there are 3 seals in the axel 2 inners and one outer for the non disconnect type it has the 2 piece axel on the pass side so why is it still leaking? is it do to the 2 iners i didnt replace? i know it was stupid not to since they where right there in all and by the way this is a 93 wrangler with a dana 30 non disconnect.


First things first. Is a disconnect axle or a NON Disconnect??? It should be a disconnect if its in a YJ. Looking from in front of the axle, there are 2 seals. One is on the outer side of the disconnect box, and the other is on the inner side of the driver side. The easiest way to replace these is to completely dis-assemble the axle and go at from the opposite side. You will need to remove the carrier to do the inner driver side anyway.

Joe

rebelBullDawg325 06-27-2007 05:54 PM

if it has the vaccuum accuator which i think you described it as having. it is a disconnect. and like joe said. easiest way to do the seals is a completely dissamble it then re-do it. make sure you clean the axle tubes out really good after you take everything apart. this way you wont tear up your new seals

payj90 06-27-2007 06:10 PM

Or instead of messing with that little d30 you could up grade to mayb a 44=). kill two birds with one stone, fix the leak and get rid of that stupid vacumn accuator.


All times are GMT -5. The time now is 09:52 PM.