Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   JK Tech Forum (http://www.wranglerforum.com/f202/)
-   -   Steam (or something) venting from under hood? (http://www.wranglerforum.com/f202/steam-or-something-venting-from-under-hood-91016.html)

MCPorche 04-26-2011 08:51 AM

Steam (or something) venting from under hood?
 
On Sunday, my 2007 Wranger was sitting under a tree, idling in park. I heard a hiss and could see some type of white steam/gas venting from under the engine compartment. It appeared to be coming from the passenger side.

I quickly turned off the engine and the venting stopped almost immediately. I opened the hood and looked around, and could find no sign of anything wrong. I didn't see any wet areas, and there was no puddling of anything under the vehicle.

The only other thing that might be of interest is that I was in four wheel drive mode at the time.

I started it up, and everything seems to be working fine.

Any ideas?

herbie 04-26-2011 09:07 AM

air conditioner may have lost some freon but only a guess

kik 04-26-2011 09:09 AM

JK's do that normally under the right atmospheric conditions believe it or not, you'll see what looks like steam coming from the front of the hood through the grill. It's condensation burning off. Don't know what the "hiss" could have been unless you had the defroster on. As long as your A/C is working properly everything should be fine. If not, then maybe there is a leak. Like I indicated, it's condensation unless the A/C no longer works.

GroundHawg 04-26-2011 09:39 AM

Quote:

Originally Posted by kik
JK's do that normally under the right atmospheric conditions believe it or not, you'll see what looks like steam coming from the front of the hood through the grill. It's condensation burning off. Don't know what the "hiss" could have been unless you had the defroster on. As long as your A/C is working properly everything should be fine. If not, then maybe there is a leak. Like I indicated, it's condensation unless the A/C no longer works.

x2

Similar thing happened to me. I was in McDonalds drive thru and I thought I was burning up :rofl: shut it down, check all fluids...everything was fine.

It was cold that night so I think it was ice/condensation melting and getting on the engine

InfernoGirl 04-26-2011 10:09 AM

Need more info... Temps? Conditions? JK rad's are right there, if it's wet for any reason they steam like crazy if it's cooler than say 200* out.... :) You only notice it when it's sitting still due to the warp speed they're usually traveling... ;)

MCPorche 04-26-2011 10:34 AM

Quote:

Originally Posted by InfernoGirl (Post 1202534)
Need more info... Temps? Conditions? JK rad's are right there, if it's wet for any reason they steam like crazy if it's cooler than say 200* out.... :) You only notice it when it's sitting still due to the warp speed they're usually traveling... ;)

Well, it was about 85* outside, and the humidity was probably in the 60% to 70% range.

If it was just some steam seeping out, I wouldn't have even worried about it...but the fact that the engine was idling, and everything was fine...and suddenly...poof...a bunch of steam and a hissing noise as if something had let go....That's what had me concerned.

I'm thinking that it could have been some freon venting. Does the Wrangler have some type of pop-off valve (or overpressure relief valve) on the A/C system?


All times are GMT -5. The time now is 04:02 AM.