Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Harmonic Balancer question. (http://www.wranglerforum.com/f218/harmonic-balancer-question-94322.html)

sjkorenek 05-18-2011 03:06 PM

Harmonic Balancer question.
 
Rebuilt 2.5 from NAPA. Just installed,, runs smooth without harmonic balancer on. Of course ran briefly. Idles rough with it on. Balancer seems to be in good shape, however , holes have been drilled (4 eighth inch holes) on one side. Could this cause a rough idle?? Plus seems that flywheel timing marks are off for the crankshaft sensor. Please help if anyone can. Thanks.....

kboles89 05-18-2011 03:44 PM

I've seen alot of gm balancers go bad because the rubber in them allows them to turn. Seeing that the 2.5 was originally produced by gm I'd put a new one on there. Give that a try, let us know what your results were.

sjkorenek 05-18-2011 03:59 PM

It points to zero on the timing scale though on TDC. Always. Are you saying it can slip with the motor running and go back to where it belongs?? Also am not understanding why the crank pos sensor will not line up on the skips in the teeth on the flywheel. This is making no sense at all.

RPM 05-18-2011 06:47 PM

Do not trust the timing mark on the ballincer!! Pull #1 plug find compression stroke, use a long thin screw driver to find TDC. spin the engine back and forth and get it as close to top as possible.. is the ballincer on TDC ?? If not the rubber in the ballincer melted and sliped.. the truck runs .. crank sensor is gettin the timing ...

kboles89 05-18-2011 09:27 PM

x2


All times are GMT -5. The time now is 11:00 AM.