Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   99 Jeep Wrangler Wont Stay Running (http://www.wranglerforum.com/f282/99-jeep-wrangler-wont-stay-running-94844.html)

MedicalNate 05-22-2011 12:54 PM

99 Jeep Wrangler Wont Stay Running
 
I bought a 99 wrangler, my guess from the owners story is someone had it in a field playing and it quit running,They put a new fuel pump drove it a mile or so then it died in there driveway they never finished working on it... has sat from a year to a year and half no with no gas lid.

I have so far, Had to Replace :

Battery
Alternator
plugs

Then it fired right up, when after it got warm it would die, now when it starts if you touch the gas it dies, if you let it idle it slowly dies then works itsself to not wanna start.

Fuel Pump Primes and sounds to be working
Got new Coil didnt make it run better
jeep doesnt use cam sensor but
tried new crank sensor didnt run better,
added heat water removing gas treatment added some fresh gas and octant boost
didnt help make it run better, checked pcm connections and
all fuses im lost now...... any ideas?

Jerry Bransford 05-22-2011 02:50 PM

Yes your TJ does use a camshaft position sensor, it is inside the distributor underneath the plastic shield underneath the distributor's rotor.

MedicalNate 05-22-2011 10:26 PM

re
 
Quote:

Originally Posted by Jerry Bransford (Post 1254937)
Yes your TJ does use a camshaft position sensor, it is inside the distributor underneath the plastic shield underneath the distributor's rotor.

perhaps i put my wrangler question in wrong catagory whats a tj? its a 99 wranger auto zone told me they dont use crankshaft sensor on 4 cy 99 4wd, if it does have it in the distributor is there a way to test it? i cleaned the tank out today emptied it cleaned off filter and put fresh gas in, still runs like hell, though when i added in gas from intake it would start and run for a second

Lando25 05-22-2011 11:33 PM

Quote:

Originally Posted by MedicalNate

perhaps i put my wrangler question in wrong catagory whats a tj? its a 99 wranger auto zone told me they dont use crankshaft sensor on 4 cy 99 4wd, if it does have it in the distributor is there a way to test it? i cleaned the tank out today emptied it cleaned off filter and put fresh gas in, still runs like hell, though when i added in gas from intake it would start and run for a second

Although im not much help with your problem a TJ is a wrangler from 97 to 06. Im sure Jerry will find you an answer like he always does.

Hostile JEEP T.J 05-23-2011 10:03 AM

Did you check the air flow sensor? Or the throttle position sensor?


All times are GMT -5. The time now is 08:47 PM.