Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   YJ Tech Forum (http://www.wranglerforum.com/f218/)
-   -   Fuel pump? (http://www.wranglerforum.com/f218/fuel-pump-95376.html)

divernaz 05-25-2011 06:46 PM

Fuel pump?
 
Got a 92 Jeep 4.0 and my brother was driving it till it ran out of gas in front of my house. I put more gas in and it wouldn't start back up. Just figured it was the fuel pump so I replaced the fuel pump and filter and it still wouldn't start up. I checked the the pressure on the fuel rail and I wasn't getting any pressure at all? I can hear the fuel pump hum, just not sure where to go from here. Thanks for all your help.

stykthyn 05-25-2011 07:23 PM

Have you checked pressure at the rail?

divernaz 05-25-2011 07:27 PM

I'm not getting any pressure at the rail, although when I press the pressure release button on my gauge I do get some fuel squirting out.

Garyk 05-25-2011 07:51 PM

Check the regulator.
How was the pickup in the tank?

divernaz 05-25-2011 08:14 PM

@ Garyk, I'm sorry but what do you mean by pickup in the tank?

Garyk 05-26-2011 03:01 PM

There is a fuel pick-up in the tank, connected to the pump, usually covered with a mesh to keep crud out....if its loose or bad that could be your problem.

divernaz 05-26-2011 06:19 PM

oh okay. I gotcha. When I replaced the fuel pump I replaced that with a new one as well. I just don't understand why I'm not getting any fuel pressure to the fuel rail.

Buddha 05-27-2011 10:15 AM

I had the same issue after replacing my fuel pump and it turned out that I had accidentally swapped the fuel lines coming from the tank. I had the fuel supply line connected to the fuel return line and vice versa. I ended up being able to swap them out without re-removing the tank by accessing them at the front of the tank on the drivers side and just swapping them around. Started right up...

divernaz 05-29-2011 12:33 AM

So I checked the fuel lines from the tank and they were on the proper way. The new fuel pump hums when I turn on the ignition. The fuel filter is pointed the right way. I've tried turning the ignition several times to prime it being fuel injected. Its still not turning over. When I put a little gas in the intake it turns over for a brief second and shuts off. I tested the pressure on the fuel rail and I'm not getting anything. I'm way confused. Do I replace the fuel regulator? Clean the fuel injectors? It's a 1992 wrangler with 65k miles on it. Really not sure what to check or do next.


All times are GMT -5. The time now is 09:15 PM.