Jeep Wrangler Forum

Jeep Wrangler Forum (
-   JK General Discussion Forum (
-   -   Strange (

Tuggin 05-27-2011 05:42 AM

I discovered yesterday that my L.H. parking light , sidemarker light and tail light do not work on my 08 JKU. I changed bulbs and still nothing. Oddly enough though is that my license plate light works. When I was trouble shooting after about 15-20 min. all the lights would go out but after turning the H.L. switch off then back on for the parking the lights came back on except for the aforementioned. I did check the ground and it is good. Does ANYONE have a clue ?????????
I really don't want to take it to the stealer and have them play with it for a couple of days.



4Jeepn 05-27-2011 05:47 AM

Any other connector you didn't check yet? Are the contacts clean?

Tuggin 05-27-2011 07:31 AM

The connector at the tail light is clean, the wires as you probably know go up through the body. I was underneath and there are not any wires I could see. At first I thought I had a bad ground because there was a little bleed though the B/U lights. I'm usually able to trace elect. problems but this one has got me scratching my head especially since my L/P light right under the T/L is working, of course being on crutches with a broken ankle dosen't help. I'm thinking there is a relay somewhere but how could all the lights work on the right side of the jeep?? any other thoughts on this??:confused:


Tuggin 05-27-2011 11:08 AM

As it turns out there is a fuse for each side if the vehicle for the lights.
We're good!!:facepalm:


All times are GMT -5. The time now is 03:13 AM.

User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2015 DragonByte Technologies Ltd.