Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   All gauges stopped working..help needed (http://www.wranglerforum.com/f282/all-gauges-stopped-working-help-needed-97008.html)

Sandy Feet 06-06-2011 05:36 PM

All gauges stopped working..help needed
 
Well, I just bought this Jeep, 97 TJ. I have disconnected an amp that wasnt working but thats about it. Today all of the gauges on the dash including the stereo is out. Nothing will come on. Any suggestions?? Thanks for any advice.

legman68 06-07-2011 01:39 AM

Hmm, I'm not sure on the stereo, but the instrument cluster is a common problem. You have to remove the shield under the steering wheel, then a few more screws, and the whole cluster will pop out, just a little pull. It's one big connector in the back, put some of that electrical grease, pop it back in, and you should be good. Oh, and don't forget to check the fuses!

MP92 06-07-2011 01:55 AM

Did you try a gauge test? If not, hold your tack and turn key to last click before start and let go of tack. Isl if this will work but good luck

Sandy Feet 06-07-2011 12:50 PM

Thanks all! It was just a stupid little fuse that I missed under the hood. Problem solved.

A1bertmarkovski 06-07-2011 02:06 PM

Thats good it was something tiny...mine would go out every once in a while and i would just pound the dash till they came back on haha


All times are GMT -5. The time now is 03:17 AM.