Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   cheap external cooling unit (http://www.wranglerforum.com/f282/cheap-external-cooling-unit-97435.html)

GoldenSahara00 06-09-2011 02:00 PM

cheap external cooling unit
 
anyone know of one for a TJ? my jeep wasnt getting near the red, but was higher than it normall gets. I think my computer was shuttin down my idle and throttle, and it wasnt lettin me rev to higher rpms after a few hours on the trail today. its pretty hot out.

Wyominer 06-09-2011 03:21 PM

Back in the day ('70's), we used to get a second windshield washer tank and pump, place the tank in the engine compartment, wire a push button (or the foot pump) into the cab, and run the fluid lines in front of the radiator. If your temp was going up, give the button a couple shots, the mist from the hoses increased the surface area on the radiator, and would bring the temp down. Very old school, and primative, but it worked! This was used on pick-ups towing in hot weather and/or hilly/rough conditions.

97wrangler-242 06-09-2011 03:42 PM

Quote:

Originally Posted by Wyominer
Back in the day ('70's), we used to get a second windshield washer tank and pump, place the tank in the engine compartment, wire a push button (or the foot pump) into the cab, and run the fluid lines in front of the radiator. If your temp was going up, give the button a couple shots, the mist from the hoses increased the surface area on the radiator, and would bring the temp down. Very old school, and primative, but it worked! This was used on pick-ups towing in hot weather and/or hilly/rough conditions.

That's a genius idea!

GoldenSahara00 06-09-2011 10:20 PM

haha sounds good but I need something that I dont gota rig, im not up for messing around with this :P

Shelby427 06-09-2011 10:40 PM

Thinking maybe a sticking thermostat. The not reving has me a little concerned.

Heating up and no revs, poor idle, could be a cat going bad too.

GoldenSahara00 06-09-2011 10:47 PM

my exhaust is all effed up... haha. dont know how the cat is. problem is I had mud all through my radiator which was probably hurting the cooling, all over the engine and everything, was doing alot of hill climbs and slow stuff for about 3 hours, alot of 4 lo on the hills, and it was like 95 out. and it was after I would let it sit shut off for a few mins. either way it was getting hotter than I like. it would only do it maybe 20 seconds then once I got moving it was fine.

the not reving concerned me too. I started it up and it wouldnt go above like 500 rpms and it usually IDLEs at around 800... lol. its fine now though on the road drove to work and home and all that. was just for a few seconds.

GoldenSahara00 06-09-2011 10:50 PM

I just wrote a big response and it deleted it... lol. I am gona check fluids andd stuff sat when i look at my rear axle.

I was mudding and do alot of hills today for about 3 hours in 95 degrees. the low reving was only for about 15 seconds after starting the jeep back up after I shut it off on the trail. idled really low then wouldnt go up even when i floored it, it wasnt even injecting gas it felt like.


All times are GMT -5. The time now is 01:48 AM.