Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Misfire Codes, Tryed EVERYTHING... except a solution... please help!!!! (http://www.wranglerforum.com/f282/misfire-codes-tryed-everything-except-a-solution-please-help-97980.html)

sdh796 06-13-2011 11:02 AM

Misfire Codes, Tryed EVERYTHING... except a solution... please help!!!!
 
Quick run down of the misfire saga...

Replaced a Oil Pressure Sending Unit a few months ago when the oil gauge went haywire... ripped a wire, spliced and replaced it... no problems.

Few weeks later, check engine light come on, engine dies... open the hood and the Crankcase Vent tube is laying on the crankcase... replace it, and the Crankcase Position Sensor...

Replaced the coil, plugs... still coming on after about 100 miles and if it gets over 65 mph or 3000 rpm....

Replaced the ECM... Engine Light comes on after about 100 miles and over 65 mph/ 3000 rpm...

Replaced the valve springs.... just came on after, you guessed it about 100 miles and over 65 mph...

Just replaced the Cam Position Sensor... betting in 100 miles and up on the highway... it will be back...

It no longer feels like it is misfiring, as it did before the Valve Spring and ECM replacement... Bought an O2 sensor, got under the jeep and then realized there were three more of them...

I am at a loss... wondering if it's a shorting wire? Can't figure out why it doesn't "feel" like it's misfiring, but still throws the codes at a predictable interval...

I am going crazy... and broke.... would love to hear ideas before I go buy three more O2 sensors... What have I missed Jerry Bransford????

Thanks!

:deadhorse:

rrich 06-13-2011 12:38 PM

It would be helpful if you told us exactly what the code numbers were.

And - Year, engine 4 - 6 etc, miles on it, modifications to the engine, and the plugs you have in it.

Shelby427 06-13-2011 01:33 PM

X2. and stop throwing parts at it, a little more time spent diagnosing it will save you a lot of misspent bucks guessing.

And I didn't see plug wires,cap,rotor on your list if it's a misfire condition.

sdh796 06-13-2011 05:14 PM

Ah... 2002 TJ, with about 75000 miles and the 4.2 straight six.....

6InARowMakesItGo 06-13-2011 05:55 PM

Quote:

Originally Posted by sdh796 (Post 1303421)
ah... 2002 tj, with about 75000 miles and the 4.2 straight six.....

4.0?

Brenonline 06-24-2011 11:15 AM

Hey sdh796:

Feels like we are having the same issue with our Jeeps and mechanics being stumped:

I have a 2002 Wrangler Sport 4.0 with 218,000 miles.

Have been dealing with this same cylinder misfire issue and then fuel injector/cylinder shut down for months now and neither the dealership nor two of my local mechanics seem to have any concrete answers.

Both dealer and local mechanics confirm cylinder misfires followed by the computer shutting down injectors to cylinders.

The dealer claims I need to have top end of the motor re-done. I do not believe them seeing as how they were absolutely convinced on two previous visits that it was the fuel pump (I'm on #3). The dealer kept claiming that the fuel pump was creating the issue. After the 3rd was replaced (by my local shop), the dealer took a look a closer look and then claimed it was not the fuel pump after all. The reason they thought it was a fuel pump issue was due to me bringing the vehicle to them hot (they never told me what condition they needed to vehicle in for accurate diagnostic). After checking it again they stated that two bad cylinders were what was causing them to give me the pressure loss in the fuel pump area. This is were they suggested machining the heads.

What has been tried to date:

Coil pack (aftermarket)
Plugs & wires
Crankshaft sensor
Carbon treatment
3 fuel pumps (dealer pump on there now).
Local shop pulled valve cover and stated that the motor looked "spotless"

Local shop did not notice significant compression loss in cylinders as claimed by dealer.

This has been a very inconsistent problem. At first (January) the cylinder shut down only occurred at + 65 miles per hour. Recently it has gotten much worse - Flashing check engine light in the morning within first two miles of travel. Cylinder shut down during city driving. This issue is happening in conjunction with hard starting (having to crank vehicle twice to get it to start). The hard starting is inconsistent as well. For weeks before bringing it into my local shop it was starting hard. After the visit to the shop it started fine.

Both my local mechanics are just about out of answers. they are pretty convinced though that I do NOT need to have the motor re-done (as suggested by dealer).

rrich 06-24-2011 04:49 PM

If BOTH of you would tell us the EXACT code you are getting we may be able to help. Just saying misfire is not specific enough. There are quite a few misfire codes, each one has a different reason for it and different fixes.

And --- Plugs - neither of you said anything about WHAT PLUGS you are using - brand and part number, and age is important.

Specific and exact Code numbers please.


All times are GMT -5. The time now is 12:27 PM.