Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   Rough Country 4" lift problem (http://www.wranglerforum.com/f282/rough-country-4-lift-problem-9872.html)

tj4tnt 07-25-2007 04:37 PM

Rough Country 4" lift problem
 
I had a local 4x4 shop install a 4" rough country lift on an '02 sahara 4.0L. Approx 2000 miles later the lower suspension arms on all for wheels are slipping at the mounting bolts. They are torqued properly and greased. I am afraid the bolts sliding back and forth will slot the holes on the mounting brackets or the bolts will fail.
Has anyone else encountered this problem and what are some ideas on how to correct the issue.

Tom

AzTJ 07-25-2007 04:47 PM

Are they the stock arm or RoughCountry ones? I'd take the arms off and inspect the bushings. They might have torn and need replacing.

tj4tnt 07-25-2007 04:50 PM

They are the rough country arms.

Scout 07-25-2007 04:57 PM

Did they use the correct bolts?

4point 07-25-2007 05:21 PM

How bout a pic of what your looking at. I have a RC 4" kit also.

"W4MAC" 07-25-2007 06:22 PM

Your making me nervous, thats the kit I just ordered.

AzTJ 07-25-2007 06:56 PM

I'm sure the installers fubard it somehow.

02Prove 07-25-2007 07:31 PM

Quote:

Originally Posted by AzTJ (Post 108755)
I'm sure the installers fubard it somehow.

x2

I've heard bad things about letting some 4WD shops install your stuff. I would call in favors and try to get help doing it yourself. If you have a Jeep club in your area I would post up asking for help. Most Jeepers will be glad to for free beer and pizza. :D


All times are GMT -5. The time now is 12:21 AM.