Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ Tech Forum (http://www.wranglerforum.com/f210/)
-   -   I've had it!! (http://www.wranglerforum.com/f210/ive-had-it-9875.html)

orange05tj 07-25-2007 05:38 PM

I've had it!!
 
Bought the Jeep with 17,000 miles and had the rear seal replaced at 21,000 miles. 3 months later and at 25,500 miles, the seal is leaking again. I know the 6 is known for leaks but come on, two times? This really sucks!

AzTJ 07-25-2007 05:41 PM

Something internal has to becausing it to wear out that fast.

The 4.0L is really only known as a long lasting powerful motor as far as I'm concerned... only leaks(one actually) is on my XJ is the valve cover @ 220K.

activelydying 07-25-2007 06:48 PM

Man, you're having a rough start.

Walkeraviator 07-25-2007 06:53 PM

See thats wierd. Mine has 80,000 miles and has spent 2 years sittin still. And it doesnt leak or burn a drop of oil. I think its bad lucj or someting for yours.

JCS05Rubi 07-25-2007 07:31 PM

I just replaced the rear main in mine. At 26,000 it was leaking like a sive. Got replaced at 19,000 when the trans was done too.

I am pretty anal about cleaning my Jeep after its been wheeled (ask penguin_in_a_cj) how long we are under my jeep spraying it down with a pressure washer the night we get home and the next day.... but dirt/sand/mud in or around the rear main will chew up the seal very fast. If your playing in sand or mud, you deffinatly want to spray out the bell housing. You can take a pressure washer and just spray inside the two vent holes (thats what I did, and 0 mud/debris inside my bell housing) or you can just remove the 4 screws or whatever it is, and spray it real good that way. You wont be able to actually get to the rear main, but getting the area clean will help more than anything.


All times are GMT -5. The time now is 04:45 AM.