Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   TJ General Discussion Forum (http://www.wranglerforum.com/f282/)
-   -   2004 Rubicon Brakes - No Power? (http://www.wranglerforum.com/f282/2004-rubicon-brakes-no-power-99478.html)

portmod7 06-23-2011 10:40 AM

2004 Rubicon Brakes - No Power?
 
Hi guys,

Just bought an '04 Rubicon. Got a great deal on it, it's super clean with NO mods...

The only issue I have with it is the brake pedal doesn't feel like I think it should. Compared to any other car with power brakes I've driven, it doesn't seem like the booster is working properly. The pedal has a stiff feel, and it takes some decent effort to get stopping power out of the brakes. A lot like when you have a car with power brakes coasting without the engine running, and you try to use the brakes to stop it. I won't say the booster flat-out isn't working, but it's effectiveness seems to be lacking a bit.

Has anyone else had this problem, got any quick tips on where I should look first, or is it not a problem and that's just the way these things feel?

Now that I think about it, I haven't tried stopping it with the engine off.... That may be a good way to determine just how bad the problem is.... Any other suggestions?

Thanks!


All times are GMT -5. The time now is 07:24 PM.


User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2016 DragonByte Technologies Ltd.