Jeep Wrangler Forum

Jeep Wrangler Forum (http://www.wranglerforum.com/)
-   General Jeep Discussion (http://www.wranglerforum.com/f19/)
-   -   Speedometer problems (http://www.wranglerforum.com/f19/speedometer-problems-9957.html)

kulahpac 07-27-2007 09:16 PM

Speedometer problems
 
Hey everyone. I was just hoping for some help. The speedometer on my 93 wrangler just stopped working. I bought a new speed sensor and put it on and it still doesn't work. I'm not quite sure what to do next. Any suggestions out there?

debruins 07-27-2007 10:02 PM

does the odometer work?

kulahpac 07-28-2007 10:46 AM

No... the odometer isn't working either... which makes it even more of a problem. I don't really know where to start now.

Tj Bunch 07-28-2007 01:52 PM

Try Taking it out and Clean The Conections for the Electrical everyone seems to say they are bad at getting Coroded (use only Electrical Cleaner NOTHING else) If that does not work you may need to replace cluster with a reman If you do get the #s off the back when it's out and Call Speed O Tach 1-800-442-4491 if that nuber does not work use this # 415-935-2040
They are here in Cali but should ship anywhere, Ask For Chris he's the Cluster Guru over there. I Buy alot from them and another place called AER In Los Angles Gm Clusters suck canal water from 99 up bad stepper motor design.

Thay will want Miles VIN# Probably Tire size Never done a jeep and of course name and payment type.

Greg

kulahpac 08-08-2008 12:08 PM

Hey everyone, I just wanted to close out this forum with a final answer for anyone else who has the same problem. I contacted Chris at Speed-O-Tach, and a week and $180 later the problem was taken care of.

Thanks for all the help.


All times are GMT -5. The time now is 03:27 PM.