Jeep Wrangler Forum - Search Results
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Search Forums

Join Wrangler Forum Today


Showing results 1 to 3 of 3
Search took 0.30 seconds.
Search: Keyword(s): ; Posts Made By: Kcrowell
Forum: YJ Tech Forum 09-11-2011, 07:29 AM
Replies: 3
Views: 1,116
Posted By Kcrowell
No help here

Well the plugs came from my local parts store, I give them the make and model of my Jeep and they had about ten different makes of plugs I could have got and all of them where OM replacement plugs,...
Forum: YJ Tech Forum 09-10-2011, 04:46 PM
Replies: 3
Views: 1,116
Posted By Kcrowell
Question 95 Jeep Wrangler 4.0L, Chugs On Acceleration and back fires sometimes

I have a 95 Wrangler 4.0 It starts and idles fine, however after driving it starts sputtering like it is not getting fuel. This only happens when driving if stopped and idling it runs fine. The...
Forum: JK General Discussion Forum 09-10-2011, 10:55 AM
Replies: 2
Views: 852
Posted By Kcrowell
Question 95 Jeep Wrangler 4.0L Chugs On Acceleration

I have a 95 Wrangler 4.0 It starts and idles fine, however after driving it starts sputtering like it is not getting fuel. This only happens when driving if stopped and idling it runs fine. The...
Showing results 1 to 3 of 3

 
Forum Jump

All times are GMT -5. The time now is 11:22 AM.



Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC