Finally got a Jeep - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By Jtaylorsjeep
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-05-2019, 07:36 AM
Thread Starter
  #1
Newb
 
Join Date: Sep 2019
Posts: 2
Finally got a Jeep

Hello all. After years of wanting a Jeep I finally have one! Bought a 2004 Wrangler x and the turn signals were flashing very fast. I read through so many posts and you tube videos before joining and posting this. All lights worked, no LED installed like some said to check, replaced a new relay switch and that fixed the problem but the hazards stopped working and when pushed down a buzzing sound only occurs. Got another one and then nothing worked. Checked the fuses all good. Switched back to original and the hazards work and lights flash fast again so I’m stumped. I haven’t read this exact problem in here but I’m sure someone has dealt with it. Any help would be appreciated!

Blue Baby Sound likes this.
Jtaylorsjeep is offline   Quote
Old 09-05-2019, 08:13 AM   #2
Thank you Veterans

5-Year WF Supporting Member
WF Lifetime Member
::WF Moderator::
 
Beastmaster's Avatar
 
Join Date: Aug 2011
Location: The Old Pubelo
Posts: 41,120
Because this is the newbie check-in area, you may not get the answers you are looking for. I suggest you check out this forum area and post your questions there, I think you'll get a better response.


https://www.wranglerforum.com/f282/

In the mean time, I just like to say . . .

Welcome to the forum!


Click here for tips on posting pictures


_______
/l ,[____],
l---L -OlllllllO-
()_) ()_)--o-)_)

Beastmaster is offline   Quote
Old 09-05-2019, 09:36 AM   #3
Professional Nap Taker

5-Year WF Supporting Member
WF Lifetime Member
::WF Moderator::
 
Blue Baby Sound's Avatar
 
Join Date: Jan 2014
Location: Glenpool, OK (Tulsa)
Posts: 14,176
Glad to have you here!
Welcome to Wrangler Forum
__________________
HERS-2018 JK- Gobi- (WOOKIEE) Build Thread
HIS- 2014 JKUR- Copperhead Pearl (BRUTUS) Build Thread
Retired 2016 JKWW- Firecracker Red (MAXIMUS)
Retired 2013 JKUS- White- (THOR)
Blue Baby Sound is offline   Quote
Sponsored Links
Advertisement
 
Old 09-05-2019, 10:45 AM   #4
THE MIGHTY GRIZZLY!

5-Year WF Supporting Member
WF Lifetime Member
::WF Moderator::
 
Old Dogger's Avatar
 
Join Date: May 2012
Location: AZ. In the Ponderosa Pine Country, where the Bears are hungry..
Posts: 25,240
to the Forum..

Congrats on your Wrangler purchase!
__________________
1974 CJ5, 2003 TJ, 2013 2 door Black Rubicon, auto, with 4.10 ratio.
Shaking at 40-70 MPH, Read this!!!

The Mighty Grizzly is not concerned,
with
the needs of the Hunter....


Click here and become a WF supporting Member
Old Dogger is offline   Quote
Old 09-06-2019, 01:45 AM   #5
Jeeper
 
MrSig's Avatar
 
Join Date: Aug 2011
Location: Davie, Fl
Posts: 33,237
and enjoy the forum!
__________________
07 JKUSR to see my mods or Jeep in action go to http://www.aaof.us/jeep.htm
CEO of Black Sheep 4x4s org,
Member of CCJ, White Jeep Club Member #137.
MrSig is offline   Quote
Old 09-08-2019, 11:09 AM   #6
Jeeper
 
Join Date: Feb 2014
Location: College Station, TX
Posts: 42
Quote:
Originally Posted by Jtaylorsjeep View Post
Hello all. After years of wanting a Jeep I finally have one! Bought a 2004 Wrangler x and the turn signals were flashing very fast. I read through so many posts and you tube videos before joining and posting this. All lights worked, no LED installed like some said to check, replaced a new relay switch and that fixed the problem but the hazards stopped working and when pushed down a buzzing sound only occurs. Got another one and then nothing worked. Checked the fuses all good. Switched back to original and the hazards work and lights flash fast again so Im stumped. I havent read this exact problem in here but Im sure someone has dealt with it. Any help would be appreciated!
Congrats! And welcome to the forum! Would agree searching in non-welcome areas of the board may be more helpful

__________________
1995 Jeep YJ - 4.0 I6, 4" lift, 33" tires, Garvin Rock Rails
. _____
/|\____
L/\\_ |"/',
..(O) (O)
mspropst is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 03:38 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC