Wrangler shenanigans - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > Community Forums > WF New Member Check In

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-21-2011, 07:16 PM
Thread Starter
  #1
Newb
 
JohnTaper's Avatar
 
Join Date: Jan 2011
Location: Bethalto, IL
Posts: 1
Wrangler shenanigans

Hello all. My name is Mike (alias, John Taper). I'm an auto tech from Illinois, although it might as well be Missouri as close to St. Louis I am. Anyway I don't actually own a jeep, but a friend of mines' dad just bought a 97 jeep wrangler with a 2.5, auto trans, and I'm his mechanic.

I figured I'd join here and spin a little yarn about the beast since I see that there are a few other people sharing similar concerns.

The head gasket was blown initially, getting antifreeze into the oil (which is most likely the cause of the current problem). I replaced the head gasket and lifters while I had the head off. Head was sent to the machine shop and done all nice like, no corners cut. It got magnafluxed, planed, new valve seals and all valves and seats were cut. So top end is solid. Took that opportunity to clean up the intake inside and out and replaced the breather elbow and seal on the back of the valve cover and new head bolts of course.

So a few weeks go by and he is driving it on a regular basis, then last week it lost oil pressure after about a 45 minute interstate drive and the engine had noticeable noise (He says). I personally couldn't get these symptoms to surface.

Either way to ease his mind I replaced the pump and pressure switch (sender). Had great oil pressure via mechanical gauge, more than it had before at idle and at higher rpm. After the pump and sender were installed I then went to drive it back to him. After about 10 miles on the interstate I was having to really put my foot in it just to keep it going, eventually only being able to achieve 45 mph. The pressure started dropping and engine noise became apparent. I pulled it over and had it towed back to the shop. It is amazing I couldn't get the same symptoms he described until I installed the new oil pump and sender. And yes everything was installed correctly, pump was primed, I even primed the entire system through the sender hole with this nice little pump we have at the shop, and pressures were verified after installation with a mechanical gauge before the new sender was installed.

Haven't looked at it again yet, as this was yesterday, but I thought it was an interesting thing to post. The engine will be coming out sooner than later and the bottom end will be rebuilt, unless anybody knows where to get a reman shortblock, I haven't been able to locate one. I will update as this happens to let ya'll know exactly what went wacky. Thing only has 80,000, sad. So there's my opening post, hope you enjoy.

Oh yeah, forgot to put when I did the head job I also replaced the cap, rotor, plugs, wires, and water pump. Painted the valve cover and water pump Chrysler engine blue. Also polished the intake so it looks pretty. Too bad it's sitting right now.

JohnTaper is offline   Quote
Old 01-21-2011, 07:39 PM   #2
Thank You Veterans

WF Lifetime Member
WF Supporting Member
::WF Administrator::
 
JDsDream's Avatar
 
Join Date: Jan 2009
Location: The Peach State
Posts: 30,757
Welcome to the Forum Mike aka John

Great story, and as always we need pics.

__________________
The kind of woman that when my feet hit the floor each morning the devil says "Oh Crap, She's up!"

To All Of Our Forum Veterans and Active Service Members.
Our Debt To You Is Greater Than We Could Ever Repay.
Thank You

__________________ThinBlueLine_________________


Become a Supporting Member!
JDsDream is offline   Quote
Old 01-21-2011, 07:44 PM   #3
Founder, ThumbJeeps

WF Supporting Member
 
Chris Larabell's Avatar
 
Join Date: Sep 2009
Location: Mid-Michigan/Thumb
Posts: 4,062
hi!
__________________
-Chris
Founder, ThumbJeeps. Mayville, Michigan
"roads are boring"


1994 Wrangler YJ I6 4.0 H/O Auto 3 spd. 3:55 Gears
Chris Larabell is offline   Quote
Sponsored Links
Advertisement
 
Old 01-21-2011, 08:32 PM   #4
Jeeper
 
baja's Avatar
 
Join Date: Oct 2009
Location: northwest iowa
Posts: 2,661
Who knows how long that motor ran with a bad head gasket.Antifreeze will pooch bearings real quick.Funny most guys come on here to complain about their mechanics!What a twist.Welcome to the forum man and good luck with the rebuild.
baja is offline   Quote
Old 01-21-2011, 08:39 PM   #5
Jeeper
 
YJjeep's Avatar
 
Join Date: Aug 2010
Location: Romney WV
Posts: 1,608
Welcome to the forum.
__________________
No longer a jeeper, BUT I will return!
YJjeep is offline   Quote
Old 01-22-2011, 01:00 AM   #6
Jeeper
 
Ageless Stranger's Avatar
 
Join Date: Apr 2010
Posts: 26,890
Welcome to WF.
Ageless Stranger is offline   Quote
Old 01-22-2011, 10:47 AM   #7
Jeeper
 
blkrubi88's Avatar
 
Join Date: Nov 2009
Location: Clayton NC
Posts: 33,208
Welcome!
__________________
I can only please one person a day and today is not your day and tomorrow is not looking good either!



CHRIS
blkrubi88 is offline   Quote
Old 01-23-2011, 02:16 PM   #8
Jeeper
 
Join Date: Jan 2011
Posts: 23
hi

shannonh is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Should I get a Wrangler? ywen JK General Discussion Forum 72 02-08-2011 07:25 PM
Newbie here looking for insight on buying a used WRANGLER mestude JK General Discussion Forum 12 01-18-2011 03:09 PM
Fellow Ohio Jeepers Help fick15 Ohio Jeep Forum 11 01-19-2010 11:56 PM
2008 Wrangler Purchase soupy1957 JK Pics Forum 23 11-22-2007 05:48 AM
4-Door Wrangler CRD Sighting? jeeptales General Jeep Discussion 4 03-31-2006 02:46 PM





All times are GMT -5. The time now is 02:56 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.