13 Jk hazards, heated seats, 110V switch going nuts - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-29-2014, 09:34 PM
Thread Starter
  #1
Newb
 
Join Date: Aug 2014
Posts: 3
13 Jk hazards, heated seats, 110V switch going nuts

Hello

I got a 2013 Sahara Moab Unlimited. 37k miles. Today I was sitting outside and noticed my' hazards turned on by themselves. I checked the switch and was not in the on position, but the switch light was flickering along with the heated seats switch, 110v switch, stablilty switch, and some other switch (all in the same cluster). Truck started fine and it went away until it came back 3 minutes later.

Anyone else
encounter this?

Mas3372 is offline   Quote
Old 08-29-2014, 09:43 PM   #2
Jeeper
 
Join Date: Jan 2013
Posts: 398
A lot of electrical issues such as yours coming up lately. I solved some electrical issues of my own by loosening and re-seating the battery terminals. Ensure they are pushed all the way down... If they are up away from the top of the battery, if there is a gap, for some reason Gremlins are released into your Jeep. Hope this helps, good luck.

RenegadeUL13 is offline   Quote
Old 08-29-2014, 11:28 PM
Thread Starter
  #3
Newb
 
Join Date: Aug 2014
Posts: 3
Thanks Renegade! I pulled my negative terminal off for an hour and just put it back on, and now it seems to be okay. Hopefully it won't come back. Thank you for your help.
Mas3372 is offline   Quote
Sponsored Links
Advertisement
 
Old 08-30-2014, 06:14 AM   #4
Jeeper
 
Join Date: Jan 2013
Posts: 398
Quote:
Originally Posted by Mas3372 View Post
Thanks Renegade! I pulled my negative terminal off for an hour and just put it back on, and now it seems to be okay. Hopefully it won't come back. Thank you for your help.
You're welcome. Oddly enough after I reset my terminals and drove around for a little while with no occurrences of my gremlins, I parked it. Only to start it up and hour later and have my wipers activate themselves. However, since that anomaly no other occurrences.
RenegadeUL13 is offline   Quote
Old 08-31-2014, 12:00 PM
Thread Starter
  #5
Newb
 
Join Date: Aug 2014
Posts: 3
Sometime when I start my jeep, my power windows won't work. If I shut it down and restart, they work fine. ...so odd
Mas3372 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 05:29 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.