2008 doors off power stays on until battery is dead - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Like Tree2Likes
  • 1 Post By JTPhoto JK
  • 1 Post By 0tter
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-09-2019, 09:07 AM
Thread Starter
  #1
Newb
 
Join Date: Jun 2019
Posts: 5
2008 doors off power stays on until battery is dead

I have searched for the fix to this thru many posts and am yet to see what the fix is. My battery is good and I did go have it tested. I have aftermarket radio and put a switch in dash to kill power to it when take doors off. I have power windows,power locks. 2008 jk Sahara. I put a test light on fuse box and it is fully powered until battery goes dead. Takes about two hours until it will no longer start same as leaving key on. If you touch the computer on Lh wheel well it is powered also because it is warm. If I have doors on and turn key off everything stays on until I break the ground by opening the door. When I do it kills all power and no problems. If I open the door first and then shut off key it kills power when key shuts off. Now when I unplug door harness (take doors off) nothing ever breaks the ground and power stays on (just like you left key on ) until battery dies. I was hoping someone has built a jumper plug to plug in drivers door harness on chassis to make it think door is open and kills power when keys is shut off? I realize this is an old question many times on here but I just have never seen an answer besides it times out (mine does not time out and can’t adjust on an 08 ) or you have a bad battery. Thanks for the help in advance.

Rollers0 is offline   Quote
Old 06-09-2019, 12:48 PM   #2
Jeeper
 
jdinny's Avatar
 
Join Date: May 2015
Location: In the woods, on a mountain, in NY
Posts: 2,040
Try this.
Go into your personal options menu, and set it to no power delay. Not sure if that's what it's called without going out and checking. Set it to turn power off with key, no delay.
See if that works for you

__________________
'12 JK Gecko | AEV 2.5/wGCB's | 315 Cooper S/T MAXX | AEV Salta's | Enhanced Rubicon rails | Trektop NX | Soft Doors | JW Speaker tail lights | M/T S1 bumper | Smitty X20-10 Comp | Factor 55 | Tactik HD spare carrier | ACE Halfback bumper | 4.10's | e-lockers | e-disconnect

ΜΟΛΩΝ ΛΑΒΕ!
jdinny is offline   Quote
Old 06-09-2019, 04:54 PM
Thread Starter
  #3
Newb
 
Join Date: Jun 2019
Posts: 5
I don’t think I have that on a 2008. This does not have steering wheel controls. Thanks though
Rollers0 is offline   Quote
Sponsored Links
Advertisement
 
Old 06-09-2019, 09:05 PM   #4
Jeeper
 
JTPhoto JK's Avatar
 
Join Date: Jun 2011
Location: Thunder Bay ON Canada
Posts: 4,332
2007 -2010 don’t have an EVIC to go into a menu. Just for the fun of it run a jumper cable from the alternator bracket to battery negative terminal and see if that kills the power when you turn the key off. 2007-2010 are noted for having bad engine ground once they get a few years old. Rear engine ground strap gets corroded and although it may look good it may not be grounding properly.
Bad grounds can do strange things.


Sent from my iPhone using Tapatalk
Lost in the woods likes this.
__________________
Jeff _(OIIIO)_

2018 Rhino Rubicon 35s for now.

08 Black and Khaki JK Sahara Unlimited (GONE) My BRUTUS BUILD
JTPhoto JK is online now   Quote
Old 06-10-2019, 06:35 AM   #5
Jeeper
 
jdinny's Avatar
 
Join Date: May 2015
Location: In the woods, on a mountain, in NY
Posts: 2,040
Quote:
Originally Posted by Rollers0 View Post
I don’t think I have that on a 2008. This does not have steering wheel controls. Thanks though
Ok, sorry. Did not know that
__________________
'12 JK Gecko | AEV 2.5/wGCB's | 315 Cooper S/T MAXX | AEV Salta's | Enhanced Rubicon rails | Trektop NX | Soft Doors | JW Speaker tail lights | M/T S1 bumper | Smitty X20-10 Comp | Factor 55 | Tactik HD spare carrier | ACE Halfback bumper | 4.10's | e-lockers | e-disconnect

ΜΟΛΩΝ ΛΑΒΕ!
jdinny is offline   Quote
Old 06-11-2019, 02:43 AM   #6
Gone Fishin

5-Year WF Supporting Member
 
ChrisNW's Avatar
 
Join Date: Feb 2017
Location: Seattle
Posts: 367
Quote:
Originally Posted by JTPhoto JK View Post
2007 -2010 don’t have an EVIC to go into a menu. Just for the fun of it run a jumper cable from the alternator bracket to battery negative terminal and see if that kills the power when you turn the key off. 2007-2010 are noted for having bad engine ground once they get a few years old. Rear engine ground strap gets corroded and although it may look good it may not be grounding properly.
Bad grounds can do strange things.


Sent from my iPhone using Tapatalk



Exactly. Electrical gremlins creep in with old braid, gnd, and connectors a lot. Good reason to always check your work.

For instance, a wire can lose some internal wires (most are multi strand) after a crimp and especially after a lot of movement.
ChrisNW is offline   Quote
Old 06-12-2019, 06:23 PM
Thread Starter
  #7
Newb
 
Join Date: Jun 2019
Posts: 5
Great idea. I just tried it and still does not work. If I unplug the door no matter what I do dash and radio stays on until battery dies. I was hoping someone had a plug they have built to plug into chassis side to jump wires to make it think door is on and open. Thanks
Rollers0 is offline   Quote
Old 06-12-2019, 07:02 PM   #8
Jeeper
 
JTPhoto JK's Avatar
 
Join Date: Jun 2011
Location: Thunder Bay ON Canada
Posts: 4,332
The problem is, is that this is not normal situation and is an indication that you have a short or ground problem somewhere. Hence no “plug” available.. Hopefully not a computer problem.


Sent from my iPhone using Tapatalk
__________________
Jeff _(OIIIO)_

2018 Rhino Rubicon 35s for now.

08 Black and Khaki JK Sahara Unlimited (GONE) My BRUTUS BUILD
JTPhoto JK is online now   Quote
Old 06-13-2019, 04:08 AM   #9
Jeeper
 
Nemo Consequentae's Avatar
 
Join Date: Sep 2018
Location: Oz
Posts: 221
Sounds strange to me. Just for reference, with the doors off, my '08 JKU shuts everything off instantly when I turn off the key. No delay.
__________________
Jeeps: Lego for grownups!
Nemo Consequentae is offline   Quote
Old 06-13-2019, 08:16 AM
Thread Starter
  #10
Newb
 
Join Date: Jun 2019
Posts: 5
Thanks for the help. I was wondering if all 08’s w electric locks and windows did this or just mine.....I think you are correct I’m going to run a fresh ground to body also otherwise I’ll see if I can find someone w an “extra” computer to try
Rollers0 is offline   Quote
Old 06-13-2019, 03:32 PM   #11
Jeeper
 
0tter's Avatar
 
Join Date: Jun 2013
Location: Oregon - Rogue Valley
Posts: 238
Stupid question, but have you checked the connectors on the cable ends that connect to your doors? Specifically looking for bent pins, foreign material causing a short etcetera?
Nemo Consequentae likes this.
__________________
Cry HAVOC and let slip the Mustelids of WAR!
0tter is offline   Quote
Old 06-14-2019, 04:06 PM   #12
Jeeper
 
Spitse's Avatar
 
Join Date: Apr 2013
Posts: 100
Did you pull the fuse for when removing doors? It’s been a while but I think it is behind the glove box. Allows you to remove doors and still have some lights turn on and off at headlight switch.

If not, try that without the switches. The switch could be wired wrong and backfeeding somehow to keep everything on instead of killing power


Sent from my iPhone using Tapatalk
Spitse is offline   Quote
Old 06-14-2019, 05:45 PM   #13
Jeeper
 
Nemo Consequentae's Avatar
 
Join Date: Sep 2018
Location: Oz
Posts: 221
I don't recall having to pull any fuse to use the interior lights with the doors off, (but only with the accessory power on, from memory.)


By everything, I meant all accessories. The headlights still do the 1 minute thing if you pull the key before turning them off.
__________________
Jeeps: Lego for grownups!
Nemo Consequentae is offline   Quote
Old Yesterday, 01:47 PM
Thread Starter
  #14
Newb
 
Join Date: Jun 2019
Posts: 5
For reference- If I open door w engine running and shut off key it kills everything. If I shut engine off w doors shut it doesn’t kill everything until I open the door. I have tested all grounds from body to Ecu and ran a new ground from battery to alternator bracket. Friend of mine has extra computer and we are going to switch it out to see if any change there.

Rollers0 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 07:11 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC