2010 horn not working. Clock spring? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-02-2014, 06:38 AM
Thread Starter
  #1
Jeeper
 
digitalbill's Avatar
 
Join Date: Jul 2013
Location: Lake Worth, FL
Posts: 499
2010 horn not working. Clock spring?

Both fuses are fine and a 12 volt tester shows no power to the fuses when the horn button is pushed.
I read a few things about the clock spring but, those write ups also say that the air bag warning light should be blinking.
On my rig, ONLY the horn(s) took a crap.
Suggestions?

digitalbill is offline   Quote
Old 12-02-2014, 02:53 PM   #2
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 8,968
It does seem like a problem with the clockspring, but before I would get into that I would re-set the system (disconnect the battery for 10 min.) and see if that takes care of it. If not then possibly a relay or the clockspring itself.
kik is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 12:56 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.