2015 JKU radiator leak - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By AlsJeep
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 05-22-2017, 11:45 AM
Thread Starter
  #1
Jeeper
 
BudMan's Avatar
 
Join Date: Jan 2010
Posts: 26
2015 JKU radiator leak

I have been trying to find a persistent radiator leak for about six months. I could smell coolant every time I stopped but it was undetectable from the front of the vehicle and there was never any residue on the ground when I stopped. I took it into a local dealer and asked them to find and repair the leak. They did a pressure check and stated, "yeah, you got a leak somewhere but we can't find it" and charged me just short of 100 bucks.

WTF ?????????????????

I continued to drive it and looking and finally took it to a dealer about forty miles away. They said they already knew about the leaks and had already located and repaired (replace the radiator) on almost a dozen 2015 and later JKs.
The leak is very small and is located on the the left (driver's side) upper rear where the coolant hose is connected. Hope this might help someone because it seems to be a common complaint:



__________________
Bud
I’ll tell you what’s wrong with society…

No one drinks from the skulls of their enemies anymore.
BudMan is offline   Quote
Old 05-22-2017, 03:17 PM   #2
Jeeper
 
AlsJeep's Avatar
 
Join Date: Oct 2014
Location: Southeast, NC
Posts: 215
Thanks BudMan. There are a few threads about these leaks. I had one on my new to me '15 with just north of 40k on the clock. Dealership replaced for free. Perhaps they (the dealership that charged yo) can give you money back or credit at the dealership, I am thinking parts department credit. It is a known issue, they shouldn't have done that to you. I would patronize the dealership that was honest with you.
cdnguy likes this.

AlsJeep is offline   Quote
Old 05-23-2017, 02:59 PM   #3
Newb
 
Join Date: Apr 2017
Location: South Carolina
Posts: 6
Just found this in my 5 day old JKU.
I found quite a few threads on the topic but didnt see a location of the leak explained, only that the radiator was replaced. Thanks for posting that.
Off to see if it's the culprit on mine..
ThickMick is offline   Quote
Sponsored Links
Advertisement
 
Old 05-27-2017, 11:57 AM   #4
Jeeper
 
Join Date: Mar 2015
Location: Calgary, Alberta
Posts: 74
Had mine replaced 3 months ago at 30,000 kms.
cdnguy is offline   Quote
Old 05-27-2017, 03:11 PM   #5
Supporting Member

5-Year WF Supporting Member
 
TerryC6's Avatar
 
Join Date: Jan 2014
Location: Hesperia, CA
Posts: 7,155
It seems all most all of then develop a leak on the drivers side.
__________________
Terry

35" Baja MTZ P3's - Level 8 Tracker Pro 5 Wheels - Dynatrac ProGrip Brakes - MetalCloak 2.5" GC Suspension, 6Pak Edition - Griffin Attenuator - Artec Front Axle Armor - Nitro Axle Sleeves - JCR Vanguard Bumpers - Poison Spyder Brawler Rockers & Bombshell Diff Covers - RockHard 4x4 Skid's & Sport Cage - Genesis Dual Battery Kit with G Screen - SPOD - Zeon 10-S - VisionX headlights - Traildash 2 - Morris Mule Trailer
TerryC6 is offline   Quote
Old 10-26-2017, 02:43 PM   #6
Jeeper
 
DURT ETR's Avatar
 
Join Date: Oct 2015
Location: So Cal in the OC
Posts: 457
Taking mine to the dealer next week for the same issue. Can smell coolant but nothing visible other than coolant reservoir keeps getting dry.
__________________
2016 JKU Rubicon - Tank Clearcoat - 4:10 gears - Remote Start - 430N Kickass Alpine factory sound system w/floor Sub - and many aftermarket mods & upgrades

Where there's a Wrangler, there's a way! [OlllllllO]
DURT ETR is offline   Quote
Old 10-26-2017, 03:12 PM   #7
Jeeper
 
Join Date: Mar 2015
Location: Calgary, Alberta
Posts: 74
Mine was replaced in the Spring....
cdnguy is offline   Quote
Old 10-26-2017, 03:20 PM   #8
Jeeper
 
0REDSOX7's Avatar
 
Join Date: Dec 2016
Posts: 899
Quote:
Originally Posted by DURT ETR View Post
Taking mine to the dealer next week for the same issue. Can smell coolant but nothing visible other than coolant reservoir keeps getting dry.
This issue is not just limited to 2015 and up JKs, my 2014 fell victim to this as well.
0REDSOX7 is offline   Quote
Old 10-26-2017, 08:20 PM   #9
Jeeper
 
nighowl2000's Avatar
 
Join Date: Sep 2014
Location: Ottawa canada
Posts: 2,082
same with mine. had pink residue on the bottom of my rad that i was finally able to trace during the winter.

__________________
2014 jku sport S dual top, auto 3.73, max tow package
Mod's - jwm4x4.com grill insert,25" eyourlife LED bar, daystar switch pod fortin remote start,rugged ridge head liners, rubicon express transmission skid plate, smittybilt 76634 SRC Side Armor
nighowl2000 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.