3.8L engine Stalls n dies - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-06-2015, 12:22 PM
Thread Starter
  #1
Guest
 
Join Date: Feb 2012
Posts: 1,412
3.8L engine Stalls n dies

07 JKU-X, 3.8L, 6spd ( bought used )
Several times in the past ( twice yesterday ! ) when taking off usually across an intersection in traffic , my engine will suddenly stall after i let the clutch out , losses RPM and dies.
No matter what I try to do to get the RPMs up it doesn't respond..
Those loaded Kenworth's get big in a hurry !!!
The engine fires right up and away I go...It gets kinda scary.
It happens in the woods too, usually after I put it in 4wd but not always.
Seems like I have read somewhere that there was a Recall for this, I haven't found it.
Just wondering if anyone else has had this problem ???

Thank's ! "BH"

84554 is offline   Quote
Old 02-06-2015, 12:51 PM   #2
Jeeper
 
Brussum's Avatar
 
Join Date: Nov 2014
Posts: 56
Is this what you're looking for?

http://project-jk.com/images/tsb/RC-G25-07.pdf

Brussum is offline   Quote
Old 02-06-2015, 02:35 PM   #3
Jeeper
 
Join Date: May 2010
Location: NW WA
Posts: 1,228
If you notice your idle drops at stoplights from 800 down to around 400 than rise back up it might be time for some new spark plugs.

First set in my 07 wore out at 50K miles. Bit of a PIA to get the to back one on the passenger side by the firewall but it can be done with a u-joint and extension.
TrueNorth is offline   Quote
Sponsored Links
Advertisement
 
Old 02-06-2015, 10:46 PM
Thread Starter
  #4
Guest
 
Join Date: Feb 2012
Posts: 1,412
Quote:
Originally Posted by Brussum View Post
Is this what you're looking for?

http://project-jk.com/images/tsb/RC-G25-07.pdf

Thank's !! I'll have the dealer check to see if mine has been "flashed"...

Thank's again !! "BH"
84554 is offline   Quote
Old 02-06-2015, 10:50 PM
Thread Starter
  #5
Guest
 
Join Date: Feb 2012
Posts: 1,412
Quote:
Originally Posted by TrueNorth View Post
If you notice your idle drops at stoplights from 800 down to around 400 than rise back up it might be time for some new spark plugs.

First set in my 07 wore out at 50K miles. Bit of a PIA to get the to back one on the passenger side by the firewall but it can be done with a u-joint and extension.
I suppose it could maybe use plugs, it's got 47K miles on it, but it runs smooth and accelerates good.
The RPM seems to be pretty steady at idle... This stalling is strange, everything feels "normal" and ya release the clutch and it'll start to move then the RPM just starts going lower and lower til it dies, by this time your right in the middle of the intersection..
Thanks for the tip ! "BH"
84554 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:27 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.