Bad shakes and code p0304 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-28-2019, 08:55 PM
Thread Starter
  #1
Newb
 
gregm311's Avatar
 
Join Date: Mar 2019
Posts: 14
Bad shakes and code p0304

Back story. 07 wrangler and got a rebuilt motor with rebuilt engine, new spark plugs and wires.

Driving home today it started to shake pretty bad. Thought it might be something with suspension then noticed it got worse when on gas pedal. Pulled over and noticed it actually cut off and the check engine light was blinking.

Limped home, plugged into scanner to find the p0304 code. Checked all wires and ended up swapping coil packs with an extra one I had laying around. Test drove and still same problem with the engine shaking, check engine light blinking and beeping.

Any help is much appreciated!

Sent from my SM-G960U using Tapatalk

gregm311 is offline   Quote
Old 03-29-2019, 11:16 AM   #2
Jeeper
 
Off Pavement's Avatar
 
Join Date: Sep 2012
Location: The Silver State
Posts: 1,491
P0304 indicates a misfire of cylinder 4. I'd look at that coil pack first.

__________________
Brian - ACŘUS
Please Support Multiple Use Of Our Public Lands
The Road To Paradise Is NOT Paved
Off Pavement is offline   Quote
Old 03-29-2019, 11:23 AM
Thread Starter
  #3
Newb
 
gregm311's Avatar
 
Join Date: Mar 2019
Posts: 14
Quote:
Originally Posted by Off Pavement View Post
P0304 indicates a misfire of cylinder 4. I'd look at that coil pack first.
Yep. Already changed the coil pack.

Sent from my SM-G960U using Tapatalk
gregm311 is offline   Quote
Sponsored Links
Advertisement
 
Old 03-29-2019, 02:53 PM   #4
Supporting Member

5-Year WF Supporting Member
 
ECSUSER's Avatar
 
Join Date: Jan 2019
Location: Rochester, MI
Posts: 398
Yank the plug next
__________________
.
.... 2007 JKU 4" lift on 35's
ECSUSER is offline   Quote
Old 03-29-2019, 03:35 PM
Thread Starter
  #5
Newb
 
gregm311's Avatar
 
Join Date: Mar 2019
Posts: 14
Doing that tonight.

Sent from my SM-G960U using Tapatalk
gregm311 is offline   Quote
Old 11-25-2019, 03:18 PM   #6
Newb
 
Join Date: Jan 2013
Posts: 12
I having same code on my 2011 JK 3.8L. What finally fixed your problem?
__________________
2011 Jeep Wrangler Sport
burchis is offline   Quote
Old 11-25-2019, 03:59 PM   #7
Jeeper
 
terpsmandan's Avatar
 
Join Date: Dec 2009
Location: Penn Yan, NY
Posts: 2,032
My wires were arcing to the coil mounting bolt. New coil and new wires. Unfortunately, the misfire sent enough fuel down the exhaust that it ruined my cats as well. P0420. Good luck.

terpsmandan is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P0301 and poor startup. PLEASE HELP! californiawrangler TJ Tech Forum 8 01-13-2014 01:10 PM
p0300 error code adkjoe TJ Tech Forum 9 09-05-2009 07:42 AM





All times are GMT -5. The time now is 12:25 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.