Bad solenoid in new winch? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-30-2015, 12:55 PM
Thread Starter
  #1
Jeeper
 
flyinion's Avatar
 
Join Date: Sep 2011
Location: Sacramento, CA
Posts: 1,994
Bad solenoid in new winch?

Hey guys, just installed a new Quadratec 9500i (integrated solenoid) winch yesterday, my first winch. I wired it direct to the battery. Started the Jeep and then checked out the winch to make sure it worked (while the Jeep was still running). Came out this morning to a nearly dead battery. I had to disconnect the winch to get it to turn over at all. I called Quadratec and they said sometimes the solenoid is bad out of the box and they're sending a new one out.

Just wanted to see if this is the likely culprit or something worse like the winch itself and I'll have to go through uninstalling it and RMA'ing the whole thing. It's mounted on a Rockhard winch plate on the stock bumper and getting that bumper on and off is not fun. The inner frame rail side bolts are a pain to get to.

__________________
2012 JKU Sport S in BFG:
Max Tow | LSD | M/T | Connectivity | Infinity | Hard Top | Ace rails | MC 2.5" lift + front TB & CA's | JCR Crusader rear bumper + Shield tire carrier | Quadratec 9500is Stealth Edition | JCR Transmission Crossmember | Quadratec Hardrock 17x8.5 | Nitto Ridge Grappler 285/75r17 | Rubi rails | JCR C gussets & LCA skids
flyinion is offline   Quote
Old 11-30-2015, 01:14 PM   #2
Jeeper
 
Join Date: Oct 2011
Location: Olympia, WA
Posts: 4,136
It does/can happen. And the biggest pain is as you have described. The winch gets its power from the solenoid.

nwbronco is offline   Quote
Old 11-30-2015, 06:02 PM   #3
Jeeper
 
Join Date: May 2014
Posts: 71
Have you hooked up a multimeter to see if it's drawing current?
thzpcs is offline   Quote
Sponsored Links
Advertisement
 
Old 11-30-2015, 07:27 PM
Thread Starter
  #4
Jeeper
 
flyinion's Avatar
 
Join Date: Sep 2011
Location: Sacramento, CA
Posts: 1,994
Quote:
Originally Posted by thzpcs View Post
Have you hooked up a multimeter to see if it's drawing current?
I haven't but that's a good idea. I do have a meter. What would be the best way to test that?
__________________
2012 JKU Sport S in BFG:
Max Tow | LSD | M/T | Connectivity | Infinity | Hard Top | Ace rails | MC 2.5" lift + front TB & CA's | JCR Crusader rear bumper + Shield tire carrier | Quadratec 9500is Stealth Edition | JCR Transmission Crossmember | Quadratec Hardrock 17x8.5 | Nitto Ridge Grappler 285/75r17 | Rubi rails | JCR C gussets & LCA skids
flyinion is offline   Quote
Old 12-20-2015, 10:04 AM   #5
Guest
 
Join Date: Jul 2013
Posts: 323
i bought a 9000i as part of a package 2 years ago for my 13 JKU. After just a couple months my entire electical system would shut down while driving for a second or two once a week or so. Then it became more frequent and I brought it to the dealer thinking my electrical system had issues. The Jeep dealer in Benton, AR is great and they kept my JK for a few days to try it and gave me a rental in the mean time. They said it had to be my winch and I said they are crazy. Well after we started logging the shorts and had 40 in less than 15 miles it was back to the dealer and they stuck to their guns. I called Quadratec and they sent a new solenoid and said it happens sometimes. I installed the new solenoid and an inline Warn solenoid and have not had any problems since.
Landers Jeep in Benton and Quadratec had the best customer service I could have wanted.
167709 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 08:05 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.