battery dead after rain - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-15-2019, 09:03 AM
Thread Starter
  #1
Jeeper
 
ylojelo's Avatar
 
Join Date: Feb 2014
Location: Virginia
Posts: 524
battery dead after rain

drove it Saturday, heavy rains on Sunday and now my one month old battery was dead this morning. The only aftermarket electrics I have added are a cb, driving lights and a headlight relay harness.

any ideas where to start?

__________________

'12 JKU Rubicon; Metalcloak 2.5" Gold Standard lift
'93 YJ
ylojelo is offline   Quote
Old 04-15-2019, 09:10 AM   #2
Jeeper
 
Hilldweller's Avatar
 
Join Date: Apr 2008
Location: Hog Waller, GA
Posts: 7,924
charge the battery, check the alternator, check the cables/grounds/terminals...

__________________
Gone camping,
Bill

"Don't it make ya wanna holla'? Don't it make ya wanna pray?
People, don't it make ya wonder what's he gonna say today?"
-- Eric Bibb
Hilldweller is online now   Quote
Old 04-15-2019, 10:06 AM   #3
Commercial Member

5-Year WF Supporting Member
 
Shark_13's Avatar
 
Join Date: Dec 2012
Location: Idaho
Posts: 6,400
Did you put a volt meter on it?
Are the terminals shiny clean (scrubbed with battery brush) and tight?
__________________
One-of-a-kind wood shift knobs for sale

https://www.wranglerforum.com/f37/han...s-1175625.html
Shark_13 is offline   Quote
Sponsored Links
Advertisement
 
Old 04-15-2019, 11:45 AM
Thread Starter
  #4
Jeeper
 
ylojelo's Avatar
 
Join Date: Feb 2014
Location: Virginia
Posts: 524
Would any of those be affected by rain?
__________________

'12 JKU Rubicon; Metalcloak 2.5" Gold Standard lift
'93 YJ
ylojelo is offline   Quote
Old 04-15-2019, 12:06 PM   #5
Jeeper
 
Join Date: Sep 2016
Location: WV
Posts: 2,113
Are you sure the battery is dead, or is there a fault somewhere after the battery?
Prages is offline   Quote
Old 04-15-2019, 12:13 PM   #6
Jeeper
 
Hilldweller's Avatar
 
Join Date: Apr 2008
Location: Hog Waller, GA
Posts: 7,924
Quote:
Originally Posted by ylojelo View Post
Would any of those be affected by rain?
The rain was likely just a coincidence.
Cold weather and a marginal battery/connections/alternator more likely.
__________________
Gone camping,
Bill

"Don't it make ya wanna holla'? Don't it make ya wanna pray?
People, don't it make ya wonder what's he gonna say today?"
-- Eric Bibb
Hilldweller is online now   Quote
Old 04-15-2019, 12:19 PM
Thread Starter
  #7
Jeeper
 
ylojelo's Avatar
 
Join Date: Feb 2014
Location: Virginia
Posts: 524
Thats what I thought, when I had the electrical checked out and replaced the battery after a big rain a month ago. And it had happened before that too, after a big rain I had to jump it.
__________________

'12 JKU Rubicon; Metalcloak 2.5" Gold Standard lift
'93 YJ
ylojelo is offline   Quote
Old 04-15-2019, 12:25 PM   #8
Jeeper
 
Hilldweller's Avatar
 
Join Date: Apr 2008
Location: Hog Waller, GA
Posts: 7,924
Quote:
Originally Posted by ylojelo View Post
Thats what I thought, when I had the electrical checked out and replaced the battery after a big rain a month ago. And it had happened before that too, after a big rain I had to jump it.
If this is strike two, smells like bad wires or bad alternator.

Disconnect the battery and put a charger on it. A good charger. Some chargers won't charge a deeply discharged battery. This is how you get around that:

While the battery is charging, check your wiring for shorts or opens. If they all look good, wait for the battery to charge. Leave it unhooked for several hours and check the voltage ---- if the voltage has dropped after being charged and there's no load, probably a bad battery. It should rest around 12.9 - 13 volts.

If the battery looks good, hook it back up and start the Jeep. Check the voltage with it running. Should be over 14 volts. If it's down in the low 13s or high 12s, bad alternator.
__________________
Gone camping,
Bill

"Don't it make ya wanna holla'? Don't it make ya wanna pray?
People, don't it make ya wonder what's he gonna say today?"
-- Eric Bibb
Hilldweller is online now   Quote
Old 04-15-2019, 12:42 PM
Thread Starter
  #9
Jeeper
 
ylojelo's Avatar
 
Join Date: Feb 2014
Location: Virginia
Posts: 524
Will do, Thanks.
__________________

'12 JKU Rubicon; Metalcloak 2.5" Gold Standard lift
'93 YJ
ylojelo is offline   Quote
Old 04-15-2019, 12:42 PM
Thread Starter
  #10
Jeeper
 
ylojelo's Avatar
 
Join Date: Feb 2014
Location: Virginia
Posts: 524
will do, Thanks Hill'
__________________

'12 JKU Rubicon; Metalcloak 2.5" Gold Standard lift
'93 YJ
ylojelo is offline   Quote
Old 04-19-2019, 12:00 PM
Thread Starter
  #11
Jeeper
 
ylojelo's Avatar
 
Join Date: Feb 2014
Location: Virginia
Posts: 524
Quote:
Originally Posted by Hilldweller View Post
The rain was likely just a coincidence.
Cold weather and a marginal battery/connections/alternator more likely.
so, Reinstalling the battery, and the terminals don't tighten to the battery posts! I had some copper flash and made some shims. And its raining heavy today. We will see.
__________________

'12 JKU Rubicon; Metalcloak 2.5" Gold Standard lift
'93 YJ
ylojelo is offline   Quote
Old 04-22-2019, 04:03 AM   #12
Jeeper
 
Hilldweller's Avatar
 
Join Date: Apr 2008
Location: Hog Waller, GA
Posts: 7,924
Quote:
Originally Posted by ylojelo View Post
so, Reinstalling the battery, and the terminals don't tighten to the battery posts! I had some copper flash and made some shims. And its raining heavy today. We will see.
Stock terminals? They should be snug....
Do you have anything attached to the main bolt? It should never have add-ons or it won't tighten.
That could be your problem all along.
__________________
Gone camping,
Bill

"Don't it make ya wanna holla'? Don't it make ya wanna pray?
People, don't it make ya wonder what's he gonna say today?"
-- Eric Bibb
Hilldweller is online now   Quote
Old 04-22-2019, 08:20 AM   #13
Jeeper
 
Old Syko's Avatar
 
Join Date: Mar 2014
Posts: 1,218
Replacing those stock terminals with something more substantial can save a lot of headaches. There are at least a couple good options.

Old Syko is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Acting like dead battery with new battery Glennsimpson87 TJ Tech Forum 4 10-03-2016 11:22 PM
rain rain rain wet floor behind passenger seat ZoranZ TJ Tech Forum 22 12-17-2014 09:38 AM
Rain rain... and some more rain. :) BirminghamTJ Pictures Forum 7 12-16-2012 09:49 PM
Rain, rain, rain, and a Leak! AmericaOverland TJ General Discussion Forum 11 01-10-2012 03:07 PM
Its dead, its not dead...its dead, its not dead!!! chrisb0108 TJ Tech Forum 10 09-15-2010 12:16 PM





All times are GMT -5. The time now is 05:06 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC