Battery problem - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-03-2016, 03:56 AM
Thread Starter
  #1
Jeeper
 
Duenas22's Avatar
 
Join Date: Mar 2014
Posts: 43
Battery problem

So i have a jeep jk 07. I have recently installed a new battery. Starting about November-ish I have been noticing my jeep acting weird. My stereo would shut off and come back on, didn't think it was a big deal till today on my way to work while waiting at a red light my dash lights all light up and then quickly went away and then my jeep completely shut off. No electricity whatsoever, couldn't even turn on hazards. It was completely off, had to get my dad to jump start it. Checked my alternator, that was good. Anyone have any idea? Thanks

Duenas22 is offline   Quote
Old 01-03-2016, 06:37 AM   #2
Jeeper
 
Excoastie's Avatar
 
Join Date: Sep 2015
Location: Bossier City, LA
Posts: 1,005
Make sure that your battery cables are both tight and clean.

It's surprising that with today's vehicles a loose or bad connection can cause all kinds of weird stuff to happen.

good luck

Exco

__________________
JKRHR, SOLD!
Build Thread
---------------------------------------------------
I'm going outside to stand.
If anyone asks, I'm OUTSTANDING
Excoastie is offline   Quote
Old 01-03-2016, 11:32 AM   #3
Newb
 
Join Date: Feb 2013
Location: Boise, ID
Posts: 12
Battery problem

I have a 2015 and while I was out wheeling all of my dash light started flashing. It looked like a lights on a Christmas tree flashing. I took the jeep to the dealers and they gave a 5 page read out of error codes. To make a long story short, they kept the jeep for two days. It end up being a dead cell in the battery. They replace the battery under warranty and I have not had an issue since. That was about 5 months ago.
ibcrwln is offline   Quote
Sponsored Links
Advertisement
 
Old 01-03-2016, 12:01 PM   #4
Jeeper
 
tony81's Avatar
 
Join Date: May 2010
Location: Denver, CO.
Posts: 162
I have a 2012 JKUR and I have had a couple of issues of it acting weird on the trail and both were the result of loose battery connections. This should be your first easy fix option. Otherwise I'd take it to the dealer under warranty. Jeeps have been known to have battery terminal connection issues. Happened in my old TJ as well. Good luck!
tony81 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 11:19 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.