Heater question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-16-2016, 08:41 AM
Thread Starter
  #1
Jeeper
 
misschung's Avatar
 
Join Date: Feb 2015
Location: CT
Posts: 236
Heater question

I have a 2015 JKU and for some reason, just noticed this issue.

When I split the heat between the top and bottom vents, the lower doesn't really seem to emit much heat. It's like all the fan power is concentrated on the top vents.

Is this something I can look at myself?

misschung is offline   Quote
Old 12-19-2016, 10:12 PM   #2
Jeeper
 
VansMudder's Avatar
 
Join Date: Mar 2012
Location: Hamilton ONT Canada, now NFLD Canada
Posts: 1,672
Being a 2015 you're still under warranty. Best thing to do is take it to the dealership service department and have them check all the blend doors. They do this via computer to see if they are opening correctly or not.

VansMudder is offline   Quote
Old 12-20-2016, 01:17 AM   #3
Jeeper
 
LowcountryJK's Avatar
 
Join Date: Apr 2015
Location: Summerville SC
Posts: 236
It has always seemed like that to me in every jeep iv been in. Maybe check another jeep to see if yours is the same.
__________________
Just here having fun!. Its not personal!
LowcountryJK is offline   Quote
Sponsored Links
Advertisement
 
Old 12-21-2016, 08:18 AM
Thread Starter
  #4
Jeeper
 
misschung's Avatar
 
Join Date: Feb 2015
Location: CT
Posts: 236
Quote:
Originally Posted by LowcountryJK View Post
It has always seemed like that to me in every jeep iv been in. Maybe check another jeep to see if yours is the same.
My mom's car is the same way, so maybe it's just because it's been in the single digits this week that I'm noticing it more. I will probably have them check it the next time I bring it in.

thanks!
misschung is offline   Quote
Old 12-24-2016, 10:06 AM   #5
Jeeper
 
Jay2011JK's Avatar
 
Join Date: Feb 2012
Location: S.E. Pa
Posts: 519
If you are still under warranty.. get back to dealer.. my 2013 had a head unit issue -- under warranty saved over $300. Good Luk
__________________
Vaya Con Dios..2 JKU's both mbrs of Real Men Use 3 Pedals" Club..
Jay2011JK is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.