Help codes P0221 and P2135 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-08-2015, 11:38 AM
Thread Starter
  #1
Newb
 
Bruceaholic's Avatar
 
Join Date: May 2013
Posts: 13
Help codes P0221 and P2135

Hoping someone can help. TPS light coming on, will go away with a restart and will come back on at random times. Went to Autozone to find out the codes and the guy suggested I replace the gas pedal because of a short. Read most of the threads about the TPS light and hadn't seen that as a solution. Before I shell out the money, wondering if that's been tried. Any help is appreciated. 2007 Sahara 2D with 25,000 miles on it. (Yes, 25,000 lol)..

Thanks,
Kathy

Bruceaholic is offline   Quote
Old 07-09-2015, 10:10 AM
Thread Starter
  #2
Newb
 
Bruceaholic's Avatar
 
Join Date: May 2013
Posts: 13
Nobody? ?

Bruceaholic is offline   Quote
Old 07-09-2015, 10:32 AM   #3
Jeeper
 
GlennB's Avatar
 
Join Date: May 2015
Location: Huffman, Tx (outside of Houston)
Posts: 304
Okeedokee.....
Both of these codes come from the TPS...the sensor on the side of the throttle body. On all the Jeeps with Electronic Throttle control there are two of everything. They didn't want runaway Jeeps (that was reserved for Toyota...but I'm kidding about that).
The logic is TPS1+TPS2 = 5v. All the time. TPS1 goes from low to high, TPS2 goes high to low. If TPS1=1v, TPS2=4v.
Anytime this correlation fails then you get P2135. P0221 indicates a problem with TPS2 circuit.
If I was jammed up and had to do the SWAG (Scientific Wild-A** Guess) method I would replace the TPS.
The difference between the TPS and the APPS:
TPS is what you "get" at the throttle blade
APPS (Accelerator Pedal Position Sensor) is mounted on the accelerator. It's what you
"want".
And like the song says, "You can't always get what you want."
Good luck!!
GlennB is offline   Quote
Sponsored Links
Advertisement
 
Old 07-09-2015, 03:00 PM
Thread Starter
  #4
Newb
 
Bruceaholic's Avatar
 
Join Date: May 2013
Posts: 13
I think I understood that lol
So don't bother with the gas pedal and just go with the TPS..
Bruceaholic is offline   Quote
Old 07-09-2015, 03:01 PM
Thread Starter
  #5
Newb
 
Bruceaholic's Avatar
 
Join Date: May 2013
Posts: 13
And thank you!!
Bruceaholic is offline   Quote
Old 07-09-2015, 03:03 PM   #6
Jeeper
 
GlennB's Avatar
 
Join Date: May 2015
Location: Huffman, Tx (outside of Houston)
Posts: 304
Roger that. You're welcome....
GlennB is offline   Quote
Old 08-31-2015, 12:44 PM   #7
Jeeper
 
Join Date: Jul 2015
Posts: 22
I am getting the exact same codes on my 2012. Did changing the TPS fix your issue?

LKLive13 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 05:00 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.