J W Speaker 8700 S.O.S. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-08-2014, 01:15 PM
Thread Starter
  #1
Newb
 
Join Date: Jan 2014
Posts: 2
J W Speaker 8700 S.O.S.

Spent a small fortune on J W Speaker 8700 lights last year, but can't figure out how to connect them. Contacted both the vendor, Mobile Centre in UK and J W Speaker, but both have not been able to assist. The main connection for the lights plug into the Jeep H4 cable without a problem, but the 8700 also have another wire which according to JW Speaker and Mobile Centre is for the position light. Problem is the connection is completely different from the stock position light wiring. Someone advised removing the position light, and going without, but that doesn't work. Attached are the pics for the lights, the connections and the original lights. Mobile Centre markets these lights as plug and play for Wrangler JK, but it doesn't seem to be the case, or I'm missing something. Please advise on how to connect these.

Attached Thumbnails
Click image for larger version

Name:	Lights.jpg
Views:	184
Size:	130.5 KB
ID:	745241  
Twist is offline   Quote
Old 02-08-2014, 03:49 PM   #2
Jeeper
 
Join Date: Oct 2011
Location: Olympia, WA
Posts: 4,136
Looks like you will need to get a connector to remedy the position connector in the harness. Or cut and splice them together. Don't feel bad about it. The US connectors are completely different for the headlights.


Bob K.

nwbronco is offline   Quote
Old 02-08-2014, 03:53 PM   #3
Jeeper
 
spinlock's Avatar
 
Join Date: Sep 2013
Location: 37.9° N, 121.7° W
Posts: 5,701
I assume you are in the UK given that the position light is an ECE requirement. I find it strange that neither the dealer or JWS could just terminates some type of simple connector, while the stock unit terminates on a bulb. It seems like you are missing a short cable with the connector on one and the correct position light on the other. Maybe they sent you an incomplete unit or one for a different country. In the worst case you could just cut the position light from the stock unit and splice it to the JWS cable assuming the bulb will fit the JWS housing. If not then you need to get a bulb that will fit the JWS housing and attach it to the cable.
__________________
"Don't take life too seriously. You'll never get out alive."
B. B.
spinlock is offline   Quote
Sponsored Links
Advertisement
 
Old 02-08-2014, 09:30 PM   #4
Jeeper
 
Jeeper909's Avatar
 
Join Date: Feb 2014
Posts: 16
Does the H-4 to H-13 adaptor not work for this application?
Jeeper909 is offline   Quote
Old 02-08-2014, 09:57 PM   #5
Jeeper
 
Join Date: Oct 2011
Location: Olympia, WA
Posts: 4,136
The EU has H4's US has H13's. It is not the light that cannot be connected. It is the left and right position bulbs.

Bob K.
nwbronco is offline   Quote
Old 02-08-2014, 10:03 PM   #6
Jeeper
 
Jeeper909's Avatar
 
Join Date: Feb 2014
Posts: 16
Quote:
Originally Posted by nwbronco View Post
The EU has H4's US has H13's. It is not the light that cannot be connected. It is the left and right position bulbs. Bob K.
Thanks for the info. I get it now.
Jeeper909 is offline   Quote
Old 02-08-2014, 10:40 PM   #7
Jeeper
 
Join Date: Oct 2011
Location: Olympia, WA
Posts: 4,136
OP, run a wire to the ?? connector and see if it works when position light is turned on. If it does, the JWS light has it included. And then you will need to make a connector from the bulb lead on the original light.


Bob K.
nwbronco is offline   Quote
Old 03-23-2014, 11:41 AM
Thread Starter
  #8
Newb
 
Join Date: Jan 2014
Posts: 2
Update on the Speaker lights - After trying all the suggestions from Forum members, still can't get the lights to work. Attempted to get in touch with the EU Sales Manager who initially tried to help, but now he is not responding to emails. Tried getting assistance through the Speaker website, and someone replied on 07 March saying the engineers are looking at it. Have been awaiting feedback ever since. This is just unbelievable lack of service. This is my first experience with JW Speaker, and I regret spending so much money for this kind of rubbish.

Twist is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 10:39 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.