Just finished lift today - BAS ESB and traction conotrol light... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-28-2016, 04:09 PM
Thread Starter
  #1
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
Just finished lift today - BAS ESB and traction conotrol light...

So they were not on when I started driving initially, but maybe 5 miles later both came on and there was a beep...

Need to get this figured out since i have to drive 30 miles to work in the morning... Is this just because I didnt use the calibration deal yet? I remember readying that it did something for traction control as well i think

chickman1313 is offline   Quote
Old 02-28-2016, 04:12 PM   #2
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
Quote:
Originally Posted by chickman1313 View Post
So they were not on when I started driving initially, but maybe 5 miles later both came on and there was a beep...

Need to get this figured out since i have to drive 30 miles to work in the morning... Is this just because I didnt use the calibration deal yet? I remember readying that it did something for traction control as well i think
Did you recenter the steering wheel?

dvn4life1972 is offline   Quote
Old 02-28-2016, 04:13 PM
Thread Starter
  #3
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
I did not, it seems pretty damn centered though
chickman1313 is offline   Quote
Sponsored Links
Advertisement
 
Old 02-28-2016, 04:14 PM   #4
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
Needs to be pretty much dead on.

Sent from my SM-N920T using Tapatalk
dvn4life1972 is offline   Quote
Old 02-28-2016, 04:18 PM
Thread Starter
  #5
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
will this affect anything driving? or can i make it through tomorrow?
chickman1313 is offline   Quote
Old 02-28-2016, 04:21 PM   #6
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
Depends how far off. No guarantees that it won't give you trouble tomorrow.

Only takes about 5 minutes if you have a helper to sit in the driver seat and tell you when to stop, etc.

Sent from my SM-N920T using Tapatalk
dvn4life1972 is offline   Quote
Old 02-28-2016, 04:25 PM
Thread Starter
  #7
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
k, guess ill do it tonight, can it be done by yourself? I have no helper
chickman1313 is offline   Quote
Old 02-28-2016, 04:27 PM   #8
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
Yep. Just turn the sleeve a little bit at a time and look at the wheel.

What year and how much lift?

Sent from my SM-N920T using Tapatalk
dvn4life1972 is offline   Quote
Old 02-28-2016, 04:29 PM
Thread Starter
  #9
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
2008 2.5 inch teraflex, going to post some pics and stuff in a bit, once im officailly DONE
chickman1313 is offline   Quote
Old 02-28-2016, 04:41 PM   #10
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
Hmmm. Not sure about pre 2012 needing that done.
@kjeeper10

Sent from my SM-N920T using Tapatalk
dvn4life1972 is offline   Quote
Old 02-28-2016, 06:04 PM
Thread Starter
  #11
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
any idea what else may cause it?
chickman1313 is offline   Quote
Old 02-28-2016, 06:07 PM   #12
Jeeper
 
Join Date: Oct 2014
Location: OC in So Cal
Posts: 1,912
Did you dislodge a sensor connector?

Did you change tires?
14Trailcrawler is offline   Quote
Old 02-28-2016, 06:52 PM
Thread Starter
  #13
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
maybe.... not sure how i would know that

yes, put on new wheels and tires, 315/75r16
chickman1313 is offline   Quote
Old 02-28-2016, 06:53 PM   #14
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
Quote:
Originally Posted by chickman1313 View Post
any idea what else may cause it?
Just did some digging. 08-11 JK'S also need the wheel centered for same reasons as 12-current.

Try adjusting the wheel, then take it for a test spin.

Sent from my SM-N920T using Tapatalk
dvn4life1972 is offline   Quote
Old 02-28-2016, 07:48 PM   #15
Supporting Member

WF Supporting Member
 
ATX14's Avatar
 
Join Date: Aug 2013
Location: Austin, TX
Posts: 1,767
X2 ^^^^

Had to do that on my '08 JKUR when I installed my RK lift.
__________________
08 JKUR-Bright Silver Metallic/Rock Krawler 3.5" X Factor Mid Arm Lift/Poison Spyder Rock Brawler Mid front & rear bumper/Poison Spyder Rocker Knockers/ Warn Zeon 10-S winch/American Racing ATX Series wheels- 37/12.5/17r BF Goodrich KO2/Adams 1310 drive shafts/Yeti tie rod/Synergy flipped drag link & ball joints/Fox ATS 2.0 steering stabilizer/Fox 2.0 dual reservoir CD adjustable shocks/G2 chrome molly front axles/Ten Factory rear axles/Reid Racing Knuckles
ATX14 is offline   Quote
Old 02-29-2016, 06:26 AM   #16
Commercial Member
 
sined240's Avatar
 
Join Date: Apr 2015
Location: Dallas
Posts: 1,550
Best way to do it is, drive straight and stop while holding the steering wheel. Then adjust to center, drive straight and stop while holding the steering wheel again. Then adjust a second time. Gets it fine tuned, rather than looking at the wheel/steering wheel, it is hard to figure out if the steering is really centered WHILE driving...
__________________
2015 JKURubicon Anvil/Black Sold Jeep
Mods: JKS JSpec 3.5 Lift/Fox 2.0, TF Alpine Frt LCA, JKS Frt Track Bar, JKS Quick Discos, SuperLift Rr Track Bar, Teraflex HD SS, Grade 8 Hdware, Griffin, Teraflex HD Hinged Carrier, Peterson/Morimoto XB LEDs, RR Evap Skid, 4.56 Gears, Adams Front DS, Spicer HD Diff Covers, Crown BBK, Synergy Rear Shock Relocation
KMC XD301 Turbine with 315/70-17 MasterCraft Courser MXT
ExpOne DX Frt Bumper / Superwinch TS9500SR
sined240 is offline   Quote
Old 02-29-2016, 07:55 AM   #17
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
OP. Did you get it taken care of?

Sent from my SM-N920T using Tapatalk
dvn4life1972 is offline   Quote
Old 02-29-2016, 10:15 AM
Thread Starter
  #18
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
will align the steering wheel this evening when i get home and let yall know if it worked. Will i need to disconnect the battery or something after to reset it or should the light just go off if it is fixed?
chickman1313 is offline   Quote
Old 02-29-2016, 10:17 AM   #19
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
Quote:
Originally Posted by chickman1313 View Post
will align the steering wheel this evening when i get home and let yall know if it worked. Will i need to disconnect the battery or something after to reset it or should the light just go off if it is fixed?
Nah. Should be okay.

Sent from my SM-N920T using Tapatalk
dvn4life1972 is offline   Quote
Old 03-02-2016, 09:27 AM
Thread Starter
  #20
Jeeper
 
chickman1313's Avatar
 
Join Date: Feb 2014
Posts: 65
Quote:
Originally Posted by dvn4life1972 View Post
Nah. Should be okay.

Sent from my SM-N920T using Tapatalk
Just an update, I adjusted the steering wheel two nights ago to what I thought was perfect, but then when I was driving I realized it was still off a little bit, the lights remained on.

Readjusted last night and got it right. Started driving this morning, about 2 miles down the road, lights turn off!

So that was the issue, just the steering wheel alignment. Really surprised me how easy it was to correct also.

Thanks a ton for the help
chickman1313 is offline   Quote
Old 03-02-2016, 09:50 AM   #21
Commercial Member
 
dvn4life1972's Avatar
 
Join Date: Jan 2014
Location: Caldwell, TX
Posts: 2,223
Quote:
Originally Posted by chickman1313 View Post
Just an update, I adjusted the steering wheel two nights ago to what I thought was perfect, but then when I was driving I realized it was still off a little bit, the lights remained on.

Readjusted last night and got it right. Started driving this morning, about 2 miles down the road, lights turn off!

So that was the issue, just the steering wheel alignment. Really surprised me how easy it was to correct also.

Thanks a ton for the help

dvn4life1972 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 08:58 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.