Newbie - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 02-10-2016, 07:47 PM
Thread Starter
  #1
Newb
 
Join Date: Feb 2016
Posts: 4
Newbie

Hi all. Thanks for letting me join.
I am in Aussie land and have just purchased a 3/2007 Wrangler JK Ultimate Rubicon.

When driving it home last night it seemed to be lagging from take off as if it had no power, it slowley builds up and seems like it is surging at the same time.

Any clues?

TIA

drbobub is offline   Quote
Old 02-10-2016, 07:48 PM
Thread Starter
  #2
Newb
 
Join Date: Feb 2016
Posts: 4
Sorry, it's the v6 petrol.

drbobub is offline   Quote
Old 02-10-2016, 11:31 PM   #3
Jeeper
 
jamant12's Avatar
 
Join Date: Nov 2015
Location: Texas
Posts: 197
Welcome and congrats on your Rubi!

Did you have any dash lights kick on? Is it an auto? There have been instances where folks have bumped their shifter from D to 1 without realizing it. What position was your transfer case in? It will help to provide folks here with as much info as you can to help you out.
jamant12 is offline   Quote
Sponsored Links
Advertisement
 
Old 02-11-2016, 01:29 AM
Thread Starter
  #4
Newb
 
Join Date: Feb 2016
Posts: 4
No woories.

Its a 6 speed manual.
just in 2wd.
No engine light at all.
drbobub is offline   Quote
Old 02-11-2016, 09:56 PM
Thread Starter
  #5
Newb
 
Join Date: Feb 2016
Posts: 4
Took off the EGR and cleaned with throttle body cleaner and refitted.
Made a definite difference.
Took 1.5 hrs.
New plugs ordered, fuel treatment done, intake done with throttle body cleaner too.
drbobub is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 06:12 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.