No driverside heat - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-08-2018, 02:20 PM
Thread Starter
  #1
Newb
 
CYNELIZZ's Avatar
 
Join Date: Oct 2012
Location: NY in the country!!!
Posts: 4
No driverside heat

2013 Sahara JK Heater Issue
No heat on the driver side out of any vent.
My mech. changed out the actuator under the glove box. $340
Still no heat on my diver side. Going back for a heater core flush this Sat.
Any advice would be appreciated.

CYNELIZZ is offline   Quote
Old 04-08-2018, 03:04 PM   #2
Jeeper
 
maddog2020's Avatar
 
Join Date: Aug 2009
Location: SoCal
Posts: 1,006
Quote:
Originally Posted by CYNELIZZ View Post
2013 Sahara JK Heater Issue
No heat on the driver side out of any vent.
My mech. changed out the actuator under the glove box. $340
Still no heat on my diver side. Going back for a heater core flush this Sat.
Any advice would be appreciated.

There are lots of threads on here about this. The solution seems to be to bleed the air out of the heater system. The nice thing about that is that it won’t cost you a penny.


Sent from my iPhone using Tapatalk

__________________
2007 JKU Sahara, 4.88 gearing, Centerforce 2 Clutch, 4" lift, 35" MT MTZ tires, K&N CAI, headers
maddog2020 is offline   Quote
Old 04-08-2018, 09:59 PM   #3
Supporting Member

5-Year WF Supporting Member
 
RoadiJeff's Avatar
 
Join Date: Dec 2012
Location: St. Louis, MO
Posts: 6,845
We had a similar problem with our 2013 Sahara. It was 43F degrees cooler out of the driver side vent than the passenger side. Sludge was discovered in the coolant recovery tank and on the radiator cap. They replaced the heater core, radiator, trans cooler and a few other things. Total cost would have been nearly $2,500 but I only had to pay a $100 ded. with my lifetime Max Care bumper-to-bumper warranty.
RoadiJeff is offline   Quote
Sponsored Links
Advertisement
 
Old 04-09-2018, 09:49 AM   #4
Jeeper
 
billetfreedom13's Avatar
 
Join Date: Feb 2018
Location: Western Mass.
Posts: 136
Also had this issue in my 2013, to the point that my driver's side vents blew cold air. I had sludge in my coolant reservoir. Did a Prestone flush, which revealed a leak in the radiator. Also made sure to independently flush out the heater core and rinse out the reservoir. Replaced radiator and refilled with new coolant. Heat is now very hot on both sides on all settings.
billetfreedom13 is offline   Quote
Old 04-14-2018, 02:41 PM
Thread Starter
  #5
Newb
 
CYNELIZZ's Avatar
 
Join Date: Oct 2012
Location: NY in the country!!!
Posts: 4
Thanks for the info. I had my heater core flushed this morning and have blazing heat again! I hope it lasts and doesn't get plugged again since I couldn't get him to change my coolant. Might be time to head else where since this is what I recommended in the first place.
CYNELIZZ is offline   Quote
Old 05-08-2018, 02:34 PM   #6
Newb
 
Join Date: Sep 2015
Posts: 2
Just had my 2013 in for this exact issue to be looked at and and we have the extended warranty. The dealership says the heater core needs replaced since its clogged which has been the usual consensus on here. Chrysler is trying to tell the dealership that they will not cover this even though I have seen this done as @RoadiJeff did above. Chrysler says its because we didnt have a flush at exactly 100k miles even though this is quoted from their site:

"Flush and replace the engine coolant at 10 years or 150,000 miles (240,000 km) whichever comes first."

https://www.mopar.com/jeep/en-us/car...-schedule.html

Funny thing is I call Mopar warranty to ask about this and the rep tells me I "should have done the maintenance and maybe changed the filter". Yes that is actually what they said about a coolant / heater issue. Where is our resident Mopar guy? I will keep the thread up to date. Right now I am waiting a return call from higher level.
DominionDave is offline   Quote
Old 05-08-2018, 02:36 PM   #7
Newb
 
Join Date: Sep 2015
Posts: 2
BTW I have 109k miles on our jeep. I forgot to state above.
DominionDave is offline   Quote
Old 05-08-2018, 03:42 PM   #8
Supporting Member

5-Year WF Supporting Member
 
TagBannedAgain's Avatar
 
Join Date: Mar 2018
Location: S.E. Michigan
Posts: 196
Quote:
Originally Posted by DominionDave View Post
Chrysler says its because we didnt have a flush at exactly 100k miles even though this is quoted from their site:

That's funny, I had to flush mine @ 91,000
TagBannedAgain is offline   Quote
Old 05-08-2018, 04:18 PM   #9
Jeeper
 
billetfreedom13's Avatar
 
Join Date: Feb 2018
Location: Western Mass.
Posts: 136
Quote:
Originally Posted by TagBannedAgain View Post
That's funny, I had to flush mine @ 91,000
Had to flush mine at 72,000 mi.
billetfreedom13 is offline   Quote
Old 05-08-2018, 05:18 PM   #10
Supporting Member

5-Year WF Supporting Member
 
RoadiJeff's Avatar
 
Join Date: Dec 2012
Location: St. Louis, MO
Posts: 6,845
Quote:
Originally Posted by DominionDave View Post
"Flush and replace the engine coolant at 10 years or 150,000 miles (240,000 km) whichever comes first."
Unless the maintenance schedule in your 2013 owner's manual says something different I don't see how they can deny a warranty claim if if wasn't flushed at 100,000 miles.

RoadiJeff is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 08:08 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.