Normal Ignition Question - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 10-15-2016, 06:34 PM
Thread Starter
  #1
Jeeper
 
Minion Wrangler's Avatar
 
Join Date: Sep 2016
Posts: 720
Normal Ignition Question

Hi all. Just got my 2017 JKUHR yesterday and ran into a snag right away. I found yesterday that when turning the Jeep off the ignition switch wouldn't detent/pop out when removing the key. This resulted in the Jeep saying the key was still in the ignition when you opened the door. If I rotated the key back to on and then back to off while jiggling the key the cylinder would pop out and no key in ignition message was given.Called the dealer and got an apt setup for Wednesday morning.

Fast forward to this afternoon the wife and I were out and about in the new Jeep. Made several stops and then finally when we got home I wasn't able to remove the key! Couldn't even get it to the off position. Finally managed to get it out by turning it forward and back a bunch and wiggling it. Was worried I'd have to disconnect the battery and try to get into the shop first thing Monday.

Used some Google-fu and found a thread that suggested making sure the cable connected to the steering column was secure. Seemed to be, but I pressed hard and thought I heard a click. Insert key again turn Jeep on and and all is well. Turned Jeep of and the key rotated back and pulled out fine. Awesome! But I found that if I did not press the key in towards the steering column during the turning off process I could still get the Jeep to think the key was in the ignition. Hmmm.

So my question is: is this normal? I've never had a vehicle do this to me before and was wondering if this is a standard Wrangler quirk or what. I swear I know how to operate a vehicle! This just seemed odd to me.

Thanks in advance!

Minion Wrangler is offline   Quote
Old 10-15-2016, 07:08 PM
Thread Starter
  #2
Jeeper
 
Minion Wrangler's Avatar
 
Join Date: Sep 2016
Posts: 720
Update. Made sure the connector was snugged and tried again. Couldn't get it to do the key in ignition error at all. Must have tried it 20 times And there ignition pooped out reach time. Can the connector actually cause the issue I experienced?

Minion Wrangler is offline   Quote
Old 10-27-2016, 08:33 PM   #3
Supporting Member

5-Year WF Supporting Member
 
Join Date: Sep 2011
Location: NY
Posts: 12
Question about 2011 JK ignition upgrade

Ignition upgrade question for a 2011 JK 3.8 engine. Does anyone have any input regarding Performance Distributors Firepower Ignition Kit 3.8L (Live Wires and Screaming Demon Coil)? According to the mfgr. the spark plug gap needs to be opened up to .065. Will this peacefully coexist with the stock computer control and will this extra voltage not eat away the spark plug electrodes faster? Any input is appreciated. I searched the forum for similar questions but couldn't find anything. Thanks-
blueknight7777 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.