P0731 Code Adjust shift points? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 07-20-2019, 10:44 AM
Thread Starter
  #1
Newb
 
Join Date: Jul 2019
Posts: 6
P0731 Code Adjust shift points?

Grasping at straws here...throwing code P0731 which appears to be the bastion of doom. That said, thought I'd at least throw it out there after reading thru other threads. I am only running 33's G2's on my `09 JKU, no gear change. Jeep has been "searching" for gears for about a year, but basically attributed it to all the things done a once: rear main seal, trans flush, RR snorkel w/k&n filter, etc., so didn't put too much thought into it as it was otherwise running well...until yest, when I had to hit brakes hard on freeway, loss of power, went to N, back to drive, and all was normal. Same thing happened on way home (rush hour, not angry driver, well, not this time-rush hour), and tran light came on. Was able to drive 25mi rest of way home, normally, no limp. When I say "searching" for gears, it basically stutters between 2nd-3rd, 4th-5th, but not an actual slip out of gear, or loss of power. So, my underlying question in all this is; would using a flashpaq (or similar) to change shift points (and a cooler) possibly fix my problem...or just rub some dirt on it and walk it off?

sven sixtu is offline   Quote
Old 07-20-2019, 04:34 PM   #2
Jeeper
 
dwtgolden's Avatar
 
Join Date: Sep 2012
Posts: 564
How many miles on the Jeep when you did the trans flush? Is that the first time the trans fluid was changed? Have you checked your trans fluid level?

Sent from my SM-G892A using Tapatalk

dwtgolden is offline   Quote
Old 07-21-2019, 09:02 AM
Thread Starter
  #3
Newb
 
Join Date: Jul 2019
Posts: 6
Quote:
Originally Posted by dwtgolden View Post
How many miles on the Jeep when you did the trans flush? Is that the first time the trans fluid was changed? Have you checked your trans fluid level?

Sent from my SM-G892A using Tapatalk


Fluid was 1st thing I checked, both warm and cold. All good. The flush was done by trusted shop at 110k after a hot oil light on beach (FL). Guys said fluid ok, not burnt, and didn’t not see any shavings of note. Attributed it all to mileage and hard driving at Jeep Beach few mo. prior. Aprox 144k mi now. Only minor mudding and weekly beach drive (just to park/leave).
sven sixtu is offline   Quote
Sponsored Links
Advertisement
 
Old 07-21-2019, 06:27 PM   #4
Jeeper
 
skjeep1's Avatar
 
Join Date: Oct 2018
Location: Slovakia
Posts: 71
it is a 3.8 or 2.8 diesel?

Because if it´s a 3.8 it has 42RLE what is a 4 speed auto.

In 2009 was 5 speed auto (545RFE) available only with diesel


If you run 33 with stock gears it is a tragedy. Especially with Sahara nad 3.73 gears.
It will hunt for gears, downshift with every touch of gas or slight uphill, mileage sucks....and the 42RLE tranny itself is quite weak, so the more you put on it the sooner it breaks.

My co-worker has Sahara which came with 3.73 and regear to 5.13 was the first job after purchase


Mine is an X-trim and came stock with 4.1 gears. With stock tyres it was somehow acceptable, but i would say 4.56 should be stock gearing or 4.88 for 31-32 tyres.


I am on 35" Coopers now (actual size is 34.5) and i am happy with 5.13
skjeep1 is offline   Quote
Old 07-22-2019, 09:42 AM
Thread Starter
  #5
Newb
 
Join Date: Jul 2019
Posts: 6
You're obviously 100% correct...its the 42LRE. Sorry, was just being dumb and could fix once posted amidst my haste, frustration, and that pesky OD it loves to search for, and you so aptly described!
sven sixtu is offline   Quote
Old 07-22-2019, 09:43 AM
Thread Starter
  #6
Newb
 
Join Date: Jul 2019
Posts: 6
*could'NT

sven sixtu is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 11:00 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC