Po128 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Like Tree2Likes
  • 1 Post By 3rdcoast jk
  • 1 Post By ylojelo
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-14-2017, 12:09 PM
Thread Starter
  #1
Jeeper
 
Jjp06489's Avatar
 
Join Date: Feb 2014
Location: Southington, CT
Posts: 49
Po128

I just put on new tires a month or two ago. Since then my check engine and low psi lights have gone on and off a few times. It seemed that when I put more air in the tires both of them would go off, and then back on a few days later. Since then the psi is off and the check engine is on. I just got it checked and the code says PO128 Thermostat. Is this a real issue that I need to get it fixed or just some bullshit?

Jjp06489 is offline   Quote
Old 10-23-2018, 11:08 AM   #2
Newb
 
Join Date: Oct 2018
Posts: 2
Same Issue

I have a 2012 Jeep Wrangler Sport with the same issue. No problems with throwing po128 code for 5 years and now I get it all the time. dealer says its a faulty thermostat or the unit that sends info regarding temp. Dealer says it will only happen when its cold out and he is right. During summer months, no code. As soon as fall hits, bammm, the code shows up. Supposedly the code throws because the engine is not warming up quick enough which is a bunch of BULL!.Engine warms up just fine and I have plenty of heat!


For now I have just been clearing the code but it ends up coming back on. I too would like to know if this is a real problem and need to have it fixed. Tired of feeding the dealer my hard earned CASH!

heresjonnie1 is offline   Quote
Old 10-23-2018, 01:48 PM   #3
Jeeper
 
Join Date: Jul 2018
Posts: 286
Just replace the thermostat, it's a normal wear item. It's cheap and easy to replace.
tonydee likes this.
3rdcoast jk is offline   Quote
Sponsored Links
Advertisement
 
Old 10-23-2018, 07:09 PM   #4
Jeeper
 
lolpetewtf's Avatar
 
Join Date: Jan 2012
Location: MA/VA/AZ
Posts: 2,319
Quote:
Originally Posted by 3rdcoast jk View Post
Just replace the thermostat, it's a normal wear item. It's cheap and easy to replace.
Nahhht
__________________
2012 Cosmos Blue JK
Galaxy DX-99v2/Sirio 5000

S Package/Auto/Dual Top
Custom Stereo/20% Tint
Grabbers on Vision Wheels
lolpetewtf is offline   Quote
Old 10-24-2018, 06:08 PM   #5
Jeeper
 
nighowl2000's Avatar
 
Join Date: Sep 2014
Location: Ottawa canada
Posts: 2,082
don't worry about the code...might be the thermostat getting stuck open. I have this issue with the wifes commander, replaced the thermostat x2 and temp sensor and she still gets that stupid code when its cold out.....
__________________
2014 jku sport S dual top, auto 3.73, max tow package
Mod's - jwm4x4.com grill insert,25" eyourlife LED bar, daystar switch pod fortin remote start,rugged ridge head liners, rubicon express transmission skid plate, smittybilt 76634 SRC Side Armor
nighowl2000 is offline   Quote
Old 01-19-2020, 09:54 PM   #6
Newb
 
Join Date: Mar 2012
Location: Syracuse, NY
Posts: 7
I am having a nightmare with that code. New PCM, Sensors, etc... Now I need in order to get inspection. The actual temperature of coolant and time it takes hits all thresholds... Dealer is soaking me. Now says the snapbacks on ribbon cable that connects to new PCM are broke therefore can't confirm that doesn't raise an issue when following the Jeep engineer workflow for trouble shooting.. Had them check pins and grounds, all good. I'm really stumped.
Eagleheagle is offline   Quote
Old 01-21-2020, 01:18 AM   #7
Supporting Member

5-Year WF Supporting Member
 
87_WhyJay's Avatar
 
Join Date: Oct 2011
Location: Mobile, Homeless, looking,
Posts: 888
Quote:
Originally Posted by Eagleheagle View Post
I am having a nightmare with that code. New PCM, Sensors, etc... Now I need in order to get inspection. The actual temperature of coolant and time it takes hits all thresholds... Dealer is soaking me. Now says the snapbacks on ribbon cable that connects to new PCM are broke therefore can't confirm that doesn't raise an issue when following the Jeep engineer workflow for trouble shooting.. Had them check pins and grounds, all good. I'm really stumped.
So what happens if the Stealership can't fix the problem and the inspector won't pass your Jeep for your annual sticker???? In Nv., if your car won't pass smog, you can pay an additional fee and go year to year with a polluting car that is putting extra money in the states pockets. Is there a work-around?
__________________
2018 JKUR Recon-Bright White/black
2018 JKR Recon-Granite Crystal Gray
2014 JKUR Bright White/Black (bought new Oct '13 TRADED IN July 2018)
1987 YJ Brown/Tan (bought 1999-sold 2018 for $8500)
1954 Willys Wagon (bought 1982, gave to father-in-law 1984)

Jeeps are BUILT, not bought!!
87_WhyJay is offline   Quote
Old 01-21-2020, 09:25 AM   #8
Jeeper
 
ssinga's Avatar
 
Join Date: May 2014
Location: Alabama
Posts: 1,427
Quote:
Originally Posted by 3rdcoast jk View Post
Just replace the thermostat, it's a normal wear item. It's cheap and easy to replace.

New theromstat assembly fixed it for me. Picked it up for $20 on Rock Auto. Easy DIY just be sure to get all the air out of the cooling systems.
__________________
My JKUS Build 2012 JKU Sahara #777,820
ssinga is offline   Quote
Old 01-21-2020, 09:58 AM   #9
Jeeper
 
LSV_Rick's Avatar
 
Join Date: Jul 2017
Location: Las Vegas
Posts: 180
New thermostat - 20 minute fix.
__________________
2013 JK Sport / Rancho 2" / Nitto RG 285-75R17 on Method NV / PS Brawler Mid Front / PS Brawler II Rear / Engo 9K / QT Aluminum Skids
LSV_Rick is offline   Quote
Old 01-24-2020, 10:28 PM   #10
Newb
 
Join Date: Mar 2012
Location: Syracuse, NY
Posts: 7
Quote:
Originally Posted by LSV_Rick View Post
New thermostat - 20 minute fix.
I've put in 3 OEM thermostats and dealer has replaced all sensors and PCM. Code still on. I noticed someone mentioned large tires and air caused PO128... Is that correct? Have paid dealer a lot of $$.
Eagleheagle is offline   Quote
Old 01-28-2020, 02:52 PM   #11
Jeeper
 
ylojelo's Avatar
 
Join Date: Feb 2014
Location: Virginia
Posts: 594
https://www.wranglerforum.com/f1373/...t-2382745.html

i get the code too, and plenty of heat and replaced the thermostat three years ago
Eagleheagle likes this.
__________________

'12 JKU Rubicon; Metalcloak 2.5" Gold Standard lift
'93 YJ Jurassic Park JP37
ylojelo is offline   Quote
Old 02-14-2020, 08:59 PM   #12
Newb
 
Join Date: Mar 2012
Location: Syracuse, NY
Posts: 7
Unfortunately it turns out there are timing sequences that the tech was able to get a clear code before it flashed the error code again. Cost $75 to pay for them to drive my jeep around... this one has everyone scratching their heads.

Eagleheagle is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:51 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.