Question about Steering Issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 01-22-2014, 09:20 AM
Thread Starter
  #1
Jeeper
 
0lllllll0's Avatar
 
Join Date: Oct 2011
Location: Albany, NY
Posts: 126
Question about Steering Issue

Hoping someone may have some ideas about a strange issue I'm having. I've had my jeep looked at by the garage at the dealership, and a mechanic at a tire garage, but no one can tell what the problem is.

When I cut the steering wheel all the way to the left the wheel offers resistance for the last 180 degree turn. Turning fully to the right is no problem. I've always been able to cut the wheel fully in either direction without issue - but now after cutting the wheel fully to the left the resistance will actually cause the steering wheel to "snap back" 180 degrees when I let go. It also seems as if the wheels are not actually turning for that last half-spin of the steering wheel. Any thoughts? I recently upgraded from stock 16s to 265-75-16s, but drove them a month before this began to happen. Also recently had an alignment done.

The dealer inspected the steering components and found no damage.

__________________
2012 JK Sport 2Door 6Speed Hardtop
0lllllll0 is offline   Quote
Old 01-22-2014, 09:22 AM   #2
Jeeper
 
lee indy's Avatar
 
Join Date: May 2009
Location: Middle Georgia
Posts: 5,799
steering sabilizer maybe shot. disco it and try again

__________________
Oscar
Director Of Public Relations
Southern Four Wheel Drive Association
My Build Thread
lee indy is offline   Quote
Old 01-22-2014, 04:59 PM
Thread Starter
  #3
Jeeper
 
0lllllll0's Avatar
 
Join Date: Oct 2011
Location: Albany, NY
Posts: 126
Bump
0lllllll0 is offline   Quote
Sponsored Links
Advertisement
 
Old 01-22-2014, 05:05 PM   #4
kik
Jeeper
 
kik's Avatar
 
Join Date: Dec 2008
Posts: 8,968
It sounds like the power steering pump may have a bad seal which could cause the issue you're describing. You should be covered under your 3/36. Since the dealer said everything else is ok I would push for them to check the pump and replace it if they can't rule it out.
kik is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 10:47 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.