RBZ 430 dash fit - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 04-15-2019, 04:35 PM
Thread Starter
  #1
Jeeper
 
Join Date: Feb 2019
Posts: 153
RBZ 430 dash fit

I just installed a RBZ head unit that I'm buying from another member here. The install was pretty easy, even using JScan to enable the rear view camera.

The issue I have is the fit in the dash seems very poor. I am upgrading from the 130 which seemed to be a bit proud of the opening, with the face of the radio sitting about 1/16" inch outside the opening, hiding the seam. The RBZ sits flush with the dash and the bottom seam is very apparent. I'm certain I have the dash fully seated and bolted in. It's almost like there should be some spacers pushing the HU out some.

Has anyone else had this same issue?

__________________
2013 Commando Green JKU Sahara
LOD Armor-Lite front bumper
BirchyBoy is offline   Quote
Old 04-15-2019, 05:42 PM   #2
Jeeper
 
dwtgolden's Avatar
 
Join Date: Sep 2012
Posts: 535
Here is a pic of my previous 730n installed. It replaced the factory 130 until I upgraded to an Alpine unit

Sent from my SM-G892A using Tapatalk

dwtgolden is offline   Quote
Old 04-15-2019, 05:59 PM   #3
Jeeper
 
jwt873's Avatar
 
Join Date: Jan 2017
Posts: 1,723
I did the 130->430 Swap in my 2016.. It fit OK. See before and after pics below.. (Click on the images to see them full size). The 430 looks like might be recessed about 1/32 inch while the 130 seemed to fit flush.
Attached Thumbnails
Click image for larger version

Name:	radio130.JPG
Views:	29
Size:	79.9 KB
ID:	4143125   Click image for larger version

Name:	radio430.JPG
Views:	36
Size:	90.6 KB
ID:	4143127  

jwt873 is offline   Quote
Sponsored Links
Advertisement
 
Old 04-15-2019, 07:56 PM   #4
Supporting Member

5-Year WF Supporting Member
 
jaysong's Avatar
 
Join Date: May 2016
Location: Prior Lake
Posts: 960
Quote:
Originally Posted by BirchyBoy View Post
I just installed a RBZ head unit that I'm buying from another member here. The install was pretty easy, even using JScan to enable the rear view camera.

The issue I have is the fit in the dash seems very poor. I am upgrading from the 130 which seemed to be a bit proud of the opening, with the face of the radio sitting about 1/16" inch outside the opening, hiding the seam. The RBZ sits flush with the dash and the bottom seam is very apparent. I'm certain I have the dash fully seated and bolted in. It's almost like there should be some spacers pushing the HU out some.

Has anyone else had this same issue?
Can you post a pic to show what you are referring to?
jaysong is offline   Quote
Old 04-15-2019, 08:30 PM
Thread Starter
  #5
Jeeper
 
Join Date: Feb 2019
Posts: 153
Quote:
Originally Posted by jwt873 View Post
I did the 130->430 Swap in my 2016.. It fit OK. See before and after pics below.. (Click on the images to see them full size). The 430 looks like might be recessed about 1/32 inch while the 130 seemed to fit flush.
Thanks. Mine is similar but the bottom edge is bowed out a bit.
__________________
2013 Commando Green JKU Sahara
LOD Armor-Lite front bumper
BirchyBoy is offline   Quote
Old 04-15-2019, 08:31 PM
Thread Starter
  #6
Jeeper
 
Join Date: Feb 2019
Posts: 153
Quote:
Originally Posted by jaysong View Post
Can you post a pic to show what you are referring to?
Yeah, Iíll post one in the morning. I do like the HU better overall but miss the preset buttons of the 130. Once I get the four camera setup done Iíll be happy
__________________
2013 Commando Green JKU Sahara
LOD Armor-Lite front bumper
BirchyBoy is offline   Quote
Old 04-16-2019, 04:35 PM   #7
dirt road inspector

WF Supporting Member
 
tomthbomb's Avatar
 
Join Date: Jun 2011
Location: Deep East Texas
Posts: 2,882
Quote:
Originally Posted by jwt873 View Post
I did the 130->430 Swap in my 2016.. It fit OK. See before and after pics below.. (Click on the images to see them full size). The 430 looks like might be recessed about 1/32 inch while the 130 seemed to fit flush.
I am on my second 430 and I've never seen that screen. Can you please enlighten me? Thanks, TTB
tomthbomb is offline   Quote
Old 04-16-2019, 04:43 PM   #8
Jeeper
 
Join Date: Nov 2018
Location: Saskatchewan, Canada
Posts: 145
Quote:
Originally Posted by tomthbomb View Post
I am on my second 430 and I've never seen that screen. Can you please enlighten me? Thanks, TTB
i was going to say the same, lol
Tikker is offline   Quote
Old 04-16-2019, 05:31 PM   #9
Jeeper
 
jwt873's Avatar
 
Join Date: Jan 2017
Posts: 1,723
The previous owner that I bought the radio from installed the Carplay for Uconnect mod.. The Carplay icons appear on the touch screen where the song and station info normally appears.

Actually it's just a still image of a Carplay screen that I installed. It doesn't actually do anything. I have a bunch of images and themes on the hard drive and cycle through them every week or so just so the dash looks a bit different
jwt873 is offline   Quote
Old 04-16-2019, 05:44 PM   #10
Jeeper
 
Join Date: Mar 2017
Posts: 198
haha was going to say nice background image! Only if...
jaybot is offline   Quote
Old 04-16-2019, 08:54 PM
Thread Starter
  #11
Jeeper
 
Join Date: Feb 2019
Posts: 153
This is not the best pic but it shows the poor fit along the bottom edge. Ignore the dirt....I should have cleaned it before installing it!
Attached Thumbnails
Click image for larger version

Name:	ABE0670E-3AF3-48E6-85A7-66CBB79D0D7C_1555466063313.jpg
Views:	17
Size:	170.5 KB
ID:	4143437  
__________________
2013 Commando Green JKU Sahara
LOD Armor-Lite front bumper
BirchyBoy is offline   Quote
Old 04-17-2019, 05:38 AM   #12
Jeeper
 
jwt873's Avatar
 
Join Date: Jan 2017
Posts: 1,723
That doesn't look right. The 130 and the 430 have the exact same dimensions and are a direct swap. The buttons on the left side should be flush with the bezel and not protruding as far as they do. So, the only thing it can be is that the radio isn't fully seated.

Perhaps there's a wire being pinched in the back which is preventing the radio from sliding all the way in.
jwt873 is offline   Quote
Old 04-17-2019, 06:34 AM   #13
Jeeper
 
dwtgolden's Avatar
 
Join Date: Sep 2012
Posts: 535
Definitely doesn't look right. I would take the dash apart again, make sure the radio is seated tight against the sub-dash and then inspect the backside of your dash to make sure you don't have a bent clip/post or a clip where the metal pulled off the plastic post and stayed in the sub-dash, specifically in the area between the radio opening and the window switch opening.

Sent from my SM-G892A using Tapatalk
dwtgolden is offline   Quote
Old 04-17-2019, 08:17 AM
Thread Starter
  #14
Jeeper
 
Join Date: Feb 2019
Posts: 153
Thanks all. I’ll take a look after work and see what’s up.
__________________
2013 Commando Green JKU Sahara
LOD Armor-Lite front bumper
BirchyBoy is offline   Quote
Old 04-17-2019, 08:27 AM   #15
Jeeper
 
Join Date: Mar 2017
Posts: 198
I have a factory installed 430n. The bezel of the radio should be flush with the plastic of the dash but the buttons on the side do stick out a bit. Especially the middle ones because they protrude out more than the top and bottom buttons.
jaybot is offline   Quote
Old 04-17-2019, 09:00 AM   #16
Jeeper
 
jwt873's Avatar
 
Join Date: Jan 2017
Posts: 1,723
Quote:
Originally Posted by jaybot View Post
I have a factory installed 430n. The bezel of the radio should be flush with the plastic of the dash but the buttons on the side do stick out a bit. Especially the middle ones because they protrude out more than the top and bottom buttons.
You're right.. All the pictures I have of the radio are from straight on. I just took a side shot of the radio and the buttons do protrude.
Attached Thumbnails
Click image for larger version

Name:	radio.jpg
Views:	13
Size:	31.2 KB
ID:	4143563  
jwt873 is offline   Quote
Old 04-17-2019, 03:13 PM   #17
dirt road inspector

WF Supporting Member
 
tomthbomb's Avatar
 
Join Date: Jun 2011
Location: Deep East Texas
Posts: 2,882
Quote:
Originally Posted by jwt873 View Post
The previous owner that I bought the radio from installed the Carplay for Uconnect mod.. The Carplay icons appear on the touch screen where the song and station info normally appears.

Actually it's just a still image of a Carplay screen that I installed. It doesn't actually do anything. I have a bunch of images and themes on the hard drive and cycle through them every week or so just so the dash looks a bit different

Cool, good idea!

tomthbomb is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I upgraded 130 to 430 RBZ and I'm not looking back. Deepjeep1371 JK General Discussion Forum 917 08-21-2018 10:27 AM
Rbz 430 radio question will it fit and work ? crableg85 JK General Discussion Forum 10 03-21-2016 07:32 PM
430 rbz en1ma JK General Discussion Forum 31 01-26-2016 03:01 PM
I just got "Sirius h/ w fail" on my Mygig 430 RBZ! wtf Deepjeep1371 JK General Discussion Forum 4 01-11-2013 08:58 AM
Need a Mygig 430 (non-nav) RBZ. High Speed Bus. With Sirius! Deepjeep1371 Classifieds Archive 9 12-28-2012 08:04 PM





All times are GMT -5. The time now is 02:17 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC