Rigid D2 SS Lights install ? - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By Colorado Dude
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 12-28-2017, 07:43 PM
Thread Starter
  #1
Jeeper
 
Colorado Dude's Avatar
 
Join Date: Jun 2012
Posts: 237
Rigid D2 SS Lights install ?

Hey guys/gals quick question I just finished installing my new D2 side shooter fog lights and they turn on/off no problem. But the toggle switch stays lit up red no matter if the lights are on or off, is this normal? Does this drain my battery?

Thanks in advance!
Aaron


Sent from my iPhone using Tapatalk

Colorado Dude is offline   Quote
Old 12-28-2017, 08:48 PM   #2
Jeeper
 
Jab1719's Avatar
 
Join Date: Jun 2015
Location: PA
Posts: 924
Yes I believe you wired the switch backwards at least thatís what happened to mine in this situation


Sent from my iPhone using Tapatalk

Jab1719 is online now   Quote
Old 12-28-2017, 09:15 PM
Thread Starter
  #3
Jeeper
 
Colorado Dude's Avatar
 
Join Date: Jun 2012
Posts: 237
Quote:
Originally Posted by Jab1719 View Post
Yes I believe you wired the switch backwards at least thatís what happened to mine in this situation


Sent from my iPhone using Tapatalk


So no red light should be on when the lights themselves are on? Correct?

Thanks!


Sent from my iPhone using Tapatalk
Colorado Dude is offline   Quote
Sponsored Links
Advertisement
 
Old 12-28-2017, 09:19 PM   #4
Jeeper
 
Jab1719's Avatar
 
Join Date: Jun 2015
Location: PA
Posts: 924
Rigid D2 SS Lights install ?

Quote:
Originally Posted by Colorado Dude View Post
So no red light should be on when the lights themselves are on? Correct?

Thanks!


Sent from my iPhone using Tapatalk


When I turn my lights on then my switch lights up. When my lights are off the switch is dark.

Just for background info mine are using a relay/fuse and wired directly to the battery.


Sent from my iPhone using Tapatalk
Jab1719 is online now   Quote
Old 12-28-2017, 09:32 PM
Thread Starter
  #5
Jeeper
 
Colorado Dude's Avatar
 
Join Date: Jun 2012
Posts: 237
Quote:
Originally Posted by Jab1719 View Post
When I turn my lights on then my switch lights up. When my lights are off the switch is dark.

Just for background info mine are using a relay/fuse and wired directly to the battery.


Sent from my iPhone using Tapatalk


Okay, got it. Iím running mine the same way, the wiring harness didnít want to disconnect very easily, so I didnít force it. Iíll force it now.


Sent from my iPhone using Tapatalk
Colorado Dude is offline   Quote
Old 12-29-2017, 12:12 AM
Thread Starter
  #6
Jeeper
 
Colorado Dude's Avatar
 
Join Date: Jun 2012
Posts: 237
So used some needle nose pliers and switched the red and blue wires. Now everything is right. Thank you Jab1719.


Sent from my iPhone using Tapatalk
Big-Wille likes this.

Colorado Dude is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 07:21 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.