Rocker Switch LED Issue - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-25-2017, 12:17 PM
Thread Starter
  #1
Newb
 
Join Date: Apr 2017
Location: Colorado
Posts: 10
Rocker Switch LED Issue

Hello All,

I have what I believe to be a wiring and/or rocker switch issue. I will insert the caveat here that I am a mechanical guy, not so much electrical but I have basic knowledge. I've tried to contact the manufacturer (MicTuning) for help but they evidently outsource their customer support to China, and the response I have received is lackluster, at best. For the record, I do not recommend these guys solely based on their customer service experience. So I'm turning to you guys and gals for some help. I've attempted to outline the issue below.

I recently purchased two Mictuning wiring harnesses to hook up my LED light bar and 4" spot lights. For the light bar I ordered the heavy duty, 300W, Fuse, 40A Relay with the "LIGHT BAR" rocker switch. For the spot lights I ordered 101039, Fuse, 40A Relay with the "SPOT LIGHTS" rocker switch. When I connected it all, with the switches in the 'OFF' position, one LED lights up on each of the switches, however, they are opposite each other, please reference attached 'Photo 01'. When the switches are in the 'ON' position both LED's light up on both of the switches, please reference 'Photo 02'. I have both of these switches wired the exact same way and per the wiring diagram provided, please reference 'Photo 03'. In an attempt to correct, I removed the switch cover and turned it 180 degrees and reinstalled it. Now the lights are on the same side, however, the switches are opposite in the 'ON' and 'OFF' positions. Please see attached 'Photo 04' and 'Photo 05'. This is closer to a solution but does not completely solve the problem.

Does anyone have any suggestions? - Thanks in advance..

Click image for larger version

Name:	Photo 01.jpg
Views:	51
Size:	195.5 KB
ID:	3727297

Click image for larger version

Name:	Photo 02.jpg
Views:	51
Size:	192.0 KB
ID:	3727305

Click image for larger version

Name:	Photo 03.jpg
Views:	64
Size:	183.8 KB
ID:	3727313

Click image for larger version

Name:	Photo 04.jpg
Views:	57
Size:	221.4 KB
ID:	3727321

Click image for larger version

Name:	Photo 05.jpg
Views:	57
Size:	182.3 KB
ID:	3727329

mevinkiller is offline   Quote
Old 08-25-2017, 01:37 PM   #2
Jeeper
 
DougM55's Avatar
 
Join Date: Jan 2012
Posts: 338
Looks like you have two different switches. Look at otrttw.net and the different switches they offer. Some have independent bottom lights while some have independent top lights. Looks like you have one of each.


Sent from my iPhone using Tapatalk

DougM55 is offline   Quote
Old 08-29-2017, 12:42 AM
Thread Starter
  #3
Newb
 
Join Date: Apr 2017
Location: Colorado
Posts: 10
Thanks DougM55, I think you are spot on. I didn't realize they made the two different types. Evidently, neither does the company that sold me the switch & wiring harness. I've pointed this out to their "customer service" manager I've been escalated to. What a joke, but thanks for helping me figure this out!
mevinkiller is offline   Quote
Sponsored Links
Advertisement
 
Old 09-05-2017, 04:47 PM
Thread Starter
  #4
Newb
 
Join Date: Apr 2017
Location: Colorado
Posts: 10
To close the loop - I finally received from feedback from the customer service, who explained the harnesses were manufactured from two different factory's. They advised to rewire it per the attached diagram and it worked afterward.
Attached Thumbnails
Click image for larger version

Name:	diagram1 new.jpg
Views:	35
Size:	42.0 KB
ID:	3740401  
mevinkiller is offline   Quote
Reply

Tags
led , opposite , rocker switch

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 10:19 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.