sluggish above 60 - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-29-2015, 02:57 PM
Thread Starter
  #1
Newb
 
Join Date: Jun 2015
Location: Colleyville
Posts: 2
sluggish above 60

I am looking at buying a 02 Rubicon with a 5 speed. Couple of concerns I would like some advice on. First the oil gauge at idle is around 70 and pegs with any throttle movement, probably a sensor but thought I would ask. More importantly, has plenty of pep in the first 3 gears but a dog in 4 and 5. At 55 mph and down shifting to 4th just has no acceleration. Is that the nature of the jeep? Engine temp runs fine.

chuck5403 is offline   Quote
Old 06-29-2015, 03:21 PM   #2
Jeeper
 
highoctane's Avatar
 
Join Date: Dec 2014
Location: Prescott, AZ
Posts: 25
First things first, the first year for the Rubicon was 2003. If it is indeed a 2002, it is not a Rubicon and will not have the parts that make it a Rubicon. Make sure you don't over pay and get ripped off. It's quite common for people to slap some stickers on the hood and pass their Jeep of as a Rubi.

__________________
Anvil 2015 Jeep Wrangler Unlimited Rubicon - stock for now.
highoctane is offline   Quote
Old 06-29-2015, 04:50 PM
Thread Starter
  #3
Newb
 
Join Date: Jun 2015
Location: Colleyville
Posts: 2
Thank you! Thank you! Thank you!
chuck5403 is offline   Quote
Sponsored Links
Advertisement
 
Old 06-29-2015, 07:57 PM   #4
Jeeper
 
15RubieJK's Avatar
 
Join Date: Dec 2014
Posts: 1,542
Quote:
Originally Posted by chuck5403 View Post
Thank you! Thank you! Thank you!
for sake of argument assuming it's not a rubicon so it would likely have the 3.07s mine in that configuration was a dog at speed even with the stock size tires. As far as the oil temp how long did you run it? Mine would peg like that for a short while until everything got good and hot.
15RubieJK is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 11:51 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.