Soft top help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-19-2014, 11:53 AM
Thread Starter
  #1
Jeeper
 
Katonc's Avatar
 
Join Date: Nov 2014
Posts: 150
Soft top help

Hey guys. I have this gap I can't fix between my soft top and door. I have tried pressing the top up and getting the Velcro to stick better. But it just isn't attaching to the frame like it should. I have this problem on both sides. Anyone else have this issue? And if so how did you fix It?

Attached Thumbnails
Click image for larger version

Name:	image_1416419617500.jpg
Views:	71
Size:	103.9 KB
ID:	1660345  
Katonc is offline   Quote
Old 11-19-2014, 12:14 PM   #2
Jeeper
 
InfoJunkie's Avatar
 
Join Date: Apr 2014
Posts: 203
Quote:
Originally Posted by Katonc View Post
Hey guys. I have this gap I can't fix between my soft top and door. I have tried pressing the top up and getting the Velcro to stick better. But it just isn't attaching to the frame like it should. I have this problem on both sides. Anyone else have this issue? And if so how did you fix It?
If it's what I think it is, you will laugh as it is simple... un-velcro the side windows (and if you must, unzip them as well). Then take that material with the bent metal inside and actually hook/insert the edge into the channel opposite the door. My dealer actually had the soft-top on incorrectly when they gave it to me and after struggling I finally read a post online that explained this is a super common issue for new owners (they simply don't know that the bent metal edge should be facing backwards inside the channel vs just resting up against the door edge.)

Hope that helps.

InfoJunkie is offline   Quote
Old 11-19-2014, 12:22 PM
Thread Starter
  #3
Jeeper
 
Katonc's Avatar
 
Join Date: Nov 2014
Posts: 150
Quote:
Originally Posted by InfoJunkie View Post
If it's what I think it is, you will laugh as it is simple... un-velcro the side windows (and if you must, unzip them as well). Then take that material with the bent metal inside and actually hook/insert the edge into the channel opposite the door. My dealer actually had the soft-top on incorrectly when they gave it to me and after struggling I finally read a post online that explained this is a super common issue for new owners (they simply don't know that the bent metal edge should be facing backwards inside the channel vs just resting up against the door edge.)

Hope that helps.
Ok gonna have a look. So it should hook into the edge opposite the door right? I think I was trying this. But maybe going about it wrong. I will look again. It happening on both sides, leads me to think they may have installed it wrong as well.
Katonc is offline   Quote
Sponsored Links
Advertisement
 
Old 11-19-2014, 12:24 PM   #4
Supporting Member

WF Supporting Member
 
Join Date: Aug 2010
Posts: 7,920
yep it happens more than you would think.....
jp2611 is offline   Quote
Old 11-19-2014, 12:35 PM   #5
Jeeper
 
Join Date: Jun 2014
Location: Southern California
Posts: 125
Haaa, this one is funny...The dealer did the same damn thing to me. They actually had it installed wrong too. took me about 4 hours to figure it out, but I did. There is also a reference in the owners manual that will help. Infojunkie is right, make sure the that long tab from the soft-top "Locks" into the channel along the door frame. You will need to un-zip the side window to do this. Do not try and do it with the window zipped, it is very difficult. Once you get the technique down, you will have your windows on and off in minutes. I would suggest once you do it and figure it out, take the windows off an on a few times soo you know how to do it so it wont be so frustrating in the future..
Ronniejr37 is offline   Quote
Old 11-19-2014, 12:36 PM   #6
Jeeper
 
InfoJunkie's Avatar
 
Join Date: Apr 2014
Posts: 203
The sad part was that I accepted the vehicle and immediately went on a long distance highway trip... when I saw the sides billowing out via the side mirrors I knew something was wrong (and I was right). Even one of the rear corner hook-ins was laying outside its channel and the center bar was ajar. I pulled over on the side of the highway, nearly took down the entire soft top, re-did the setup from the ground up to fix the issues. I actually was just looking at my data-phone the entire time for directions/tips. The nice thing is that I was forced to take a crash course in setting up/putting down the soft top (not necessarily a bad thing).
InfoJunkie is offline   Quote
Old 11-19-2014, 01:23 PM   #7
Jeeper
 
Join Date: May 2010
Location: NW WA
Posts: 1,228
The plastic snap in channel above the door is a monkey puzzle too.

Once you "get it" you've got it. Until then it just doesn't make any sense.
TrueNorth is offline   Quote
Old 11-19-2014, 03:46 PM
Thread Starter
  #8
Jeeper
 
Katonc's Avatar
 
Join Date: Nov 2014
Posts: 150
Quote:
Originally Posted by TrueNorth View Post
The plastic snap in channel above the door is a monkey puzzle too.

Once you "get it" you've got it. Until then it just doesn't make any sense.
Sounds like a common problem haha. So I went out at lunch to see, and yeah I think they just installed it wrong. I see what you guys are saying. I have to fix this on both sides.

So I am assuming under the velcro there is a zipper, and that is what you guys are referring to when saying take it out. I will hopefully get to this tonight, and let you all know how it goes!
Katonc is offline   Quote
Old 11-22-2014, 12:47 PM
Thread Starter
  #9
Jeeper
 
Katonc's Avatar
 
Join Date: Nov 2014
Posts: 150
Fixed it! Thanks for the help. The dealer must have installed it wrong. It's looking good now!

Katonc is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 01:05 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.