Strange electric issues after engine swap... - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 09-05-2016, 09:26 AM
Thread Starter
  #1
Jeeper
 
Sparkdawg's Avatar
 
Join Date: Jun 2014
Posts: 84
Strange electric issues after engine swap...

Since I got my new engine my dashboard has been lighting up like a Christmas tree. Here are the 3 main issues;

All at the same time my esp, traction, abs, and break light will come on and my speedometer will drop (sometimes headlights will dim). Sometimes it's when I hit a bump, sometimes it's when I'm driving on even straight road.

Radio will randomly turn off and back on.

Air bag lights, driver or passenger will randomly turn on then off again.

Check engine light just came on, so I'm hoping that will answer more questions than it raises.

Sparkdawg is offline   Quote
Old 09-05-2016, 07:38 PM
Thread Starter
  #2
Jeeper
 
Sparkdawg's Avatar
 
Join Date: Jun 2014
Posts: 84
Check engine light was for the o2 sensor. Does all of this ever come into a harness that might be loose or messed up?

Sparkdawg is offline   Quote
Old 09-06-2016, 11:09 AM   #3
Jeeper
 
tony81's Avatar
 
Join Date: May 2010
Location: Denver, CO.
Posts: 161
I would try your battery connections. They are known to be issues. I experience the dash going bonkers on me while driving and trying to track down tighter battery terminals.
tony81 is offline   Quote
Sponsored Links
Advertisement
 
Old 09-07-2016, 06:38 PM   #4
Guest
 
Join Date: Feb 2015
Posts: 669
check your ground leads. sounds like a loose ground...
767282 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 04:54 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.