Sway bar - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > JK Jeep Wrangler Forum > JK Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 11-26-2014, 12:15 PM
Thread Starter
  #1
Newb
 
Join Date: Aug 2014
Posts: 1
Sway bar

I have been having an intermittent issue with my ESD on a 2014 Rubicon X. Seems like it might loose connection to the disconnect unit. The sway bar light keeps coming on during normal conditions but the sway bar is still connected.

Any thoughts?

mpsalary is offline   Quote
Old 11-26-2014, 12:49 PM   #2
Jeeper
 
eldomi809's Avatar
 
Join Date: Aug 2013
Location: Boston,Ma
Posts: 387
Bad connector .. document it , have some one record the dash as you drive around or strap a gopro to your check and record the dash. This will prevent the dealer from saying they cant reproduce the issue. The swaybar issue is well know in the forums.
eldomi809 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 08:52 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.