1998 jeep wrangler problems - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Like Tree1Likes
  • 1 Post By Shark_13
Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 08-06-2019, 03:45 PM
Thread Starter
  #1
Newb
 
Join Date: Aug 2019
Posts: 4
1998 jeep wrangler problems

Hi, I'm new to this site and need some help.
I have a 1998 jeep wrangler, 4.0 engine, 5 speed trans.
My problem is when I first take off it runs fine til 3rd or 4th gear then
Starts to Spit and sputter like it's running out of gas. If I push in the clutch and turn off the ignition then restart it and it runs fine. Any ideas what might be going on with it?

dmuntz is offline   Quote
Old 08-06-2019, 04:21 PM   #2
Commercial Member

5-Year WF Supporting Member
 
Shark_13's Avatar
 
Join Date: Dec 2012
Location: Idaho
Posts: 6,744
Any codes?
When was the last time you checked plugs, wires etc.
Fuel pressure?
crallscars likes this.

__________________
One-of-a-kind wood shift knobs for sale

https://www.wranglerforum.com/f37/han...s-1175625.html
Shark_13 is offline   Quote
Old 08-06-2019, 06:37 PM
Thread Starter
  #3
Newb
 
Join Date: Aug 2019
Posts: 4
Quote:
Originally Posted by dmuntz View Post
Hi, I'm new to this site and need some help.
I have a 1998 jeep wrangler, 4.0 engine, 5 speed trans.
My problem is when I first take off it runs fine til 3rd or 4th gear then
Starts to Spit and sputter like it's running out of gas. If I push in the clutch and turn off the ignition then restart it and it runs fine. Any ideas what might be going on with it?
Quote:
Originally Posted by Shark_13 View Post
Any codes?
When was the last time you checked plugs, wires etc.
Fuel pressure?
n
No codes no check engine light. I read that it could be the MAPP sensor, got one put it on didn't help. Gonna put a duel filter on it next.
dmuntz is offline   Quote
Sponsored Links
Advertisement
 
Old 08-06-2019, 06:56 PM   #4
Jeeper
 
Join Date: Jan 2014
Location: West Texas
Posts: 90
5 Speed manual?

Are the RPMs high when it starts sputtering, approx 2.5-3K?
Checked the fuel pressure?
Checked Spark plugs (much easier than with a JK 3.6L ugghh!!! )

Mine issue was with a 2001. Fuel pump THEN a misaligned camshaft positioning (explained in post linked).
https://www.wranglerforum.com/f210/m...l#post25905593
Sarkaukar2000 is offline   Quote
Old 08-07-2019, 12:40 AM   #5
Commercial Member

5-Year WF Supporting Member
 
Shark_13's Avatar
 
Join Date: Dec 2012
Location: Idaho
Posts: 6,744
Quote:
Originally Posted by dmuntz View Post
n
No codes no check engine light. I read that it could be the MAPP sensor, got one put it on didn't help. Gonna put a duel filter on it next.
Don't play parts darts, you'll end up spending a lot just throwing random parts at it.

You can rent various diagnostics tools from AutoZone for free .
__________________
One-of-a-kind wood shift knobs for sale

https://www.wranglerforum.com/f37/han...s-1175625.html
Shark_13 is offline   Quote
Old 08-07-2019, 12:47 AM   #6
Jeeper
 
meatsock's Avatar
 
Join Date: Jul 2019
Location: magnolia mass
Posts: 33
Fuel filter?
meatsock is offline   Quote
Old 08-07-2019, 08:22 AM   #7
Commercial Member

5-Year WF Supporting Member
 
Shark_13's Avatar
 
Join Date: Dec 2012
Location: Idaho
Posts: 6,744
Tjs don't have a separate fuel filter, it's built into the pump in the tank...
__________________
One-of-a-kind wood shift knobs for sale

https://www.wranglerforum.com/f37/han...s-1175625.html
Shark_13 is offline   Quote
Old 08-07-2019, 11:56 PM   #8
Jeeper
 
meatsock's Avatar
 
Join Date: Jul 2019
Location: magnolia mass
Posts: 33
ahhhh, guess i never noticed that
meatsock is offline   Quote
Old 08-10-2019, 06:03 AM   #9
Newb
 
Join Date: Dec 2018
Posts: 13
Quote:
Originally Posted by dmuntz View Post
Hi, I'm new to this site and need some help.
I have a 1998 jeep wrangler, 4.0 engine, 5 speed trans.
My problem is when I first take off it runs fine til 3rd or 4th gear then
Starts to Spit and sputter like it's running out of gas. If I push in the clutch and turn off the ignition then restart it and it runs fine. Any ideas what might be going on with it?
Does it ever spit and sputter at idle? If you crank the jeep and leave it sitting?
Deltacottonboy12 is offline   Quote
Old 08-12-2019, 06:20 PM
Thread Starter
  #10
Newb
 
Join Date: Aug 2019
Posts: 4
no idles fine, just does it usually when I get to 3rd or 4th gear.
when it does I push in the clutch kill the engine wait a couple of seconds a start it back up
and it runs fine.

dmuntz is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 03:16 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeepģ, Wrangler, Liberty, Wagoneer, Cherokee, and Grand Cherokee are copyrighted and trademarked to Chrysler Motors LLC.
Wranglerforum.com is not in any way associated with the Chrysler Motors LLC