1998 Sahara No horn no lighter cruise & all else OK - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-31-2016, 10:01 PM
Thread Starter
  #1
Jeeper
 
Zarranz's Avatar
 
Join Date: Jul 2012
Location: Cape Coral, FL
Posts: 36
1998 Sahara No horn no lighter cruise & all else OK

The horn on my Sahara is not working and neither is the cigarette lighter which I use to charge my phone. Everything else is working fine. No air bag warning light or cruise control problems. I checked all fuse in glove box and all OK Can anyone help? Thanks in advance.

Zarranz is offline   Quote
Old 04-01-2016, 08:12 AM   #2
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 3,086
Check the fuses under the hood-passenger side.

Wattapunk is offline   Quote
Old 04-01-2016, 08:31 PM
Thread Starter
  #3
Jeeper
 
Zarranz's Avatar
 
Join Date: Jul 2012
Location: Cape Coral, FL
Posts: 36
All fuses OK

Check all fuses in fuse panel behind glove box AND PCM in engine compartment on the passenger side and all are OK. Still no horn and no lighter. Had it out on the road today and no indication of clock spring problem. I need help!
Zarranz is offline   Quote
Sponsored Links
Advertisement
 
Old 04-01-2016, 09:33 PM   #4
Jeeper
 
Join Date: Apr 2013
Posts: 13,019
I think he means fuses behind glove box and in the PDC
Digger84 is offline   Quote
Old 04-02-2016, 08:36 AM
Thread Starter
  #5
Jeeper
 
Zarranz's Avatar
 
Join Date: Jul 2012
Location: Cape Coral, FL
Posts: 36
Yes I checked all fuses in the panel behind glove box and the PDC and all are good. I head click at relay for horn in the PDC when horn is pressed but still no horn or lighter power.
Zarranz is offline   Quote
Old 04-02-2016, 09:10 AM   #6
Jeeper
 
Join Date: Apr 2013
Posts: 13,019
Horn power battery to fuse 20 to relay to horns

Cigar lighter battery to fuse 5 to accessory relay to fuse 19 to cigar lighter outlet
Digger84 is offline   Quote
Old 04-02-2016, 10:00 AM   #7
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 3,086
Get out a voltmeter and check for 12v at both horn and cig lighter connectors along with fuse locations to start narrowing it down to source.
Wattapunk is offline   Quote
Old 04-02-2016, 05:44 PM
Thread Starter
  #8
Jeeper
 
Zarranz's Avatar
 
Join Date: Jul 2012
Location: Cape Coral, FL
Posts: 36
Partly fixed

Tested the voltage at the horn connector and got 12 v that was were the problem was. The plastic connector is corroding. I am looking for a new one. But that problem is solved. Took apart dash and have no power at cigar lighter where do these wires come from. I know they are switched
Zarranz is offline   Quote
Old 04-02-2016, 06:00 PM   #9
Jeeper
 
Join Date: Apr 2013
Posts: 13,019
Read my post battery to fuse 5 to accessory relay to fuse 19 to cigar lighter
Digger84 is offline   Quote
Old 04-03-2016, 09:23 AM   #10
Jeeper
 
Wattapunk's Avatar
 
Join Date: Mar 2012
Location: North TX
Posts: 3,086
Quote:
Originally Posted by Digger84 View Post
Read my post battery to fuse 5 to accessory relay to fuse 19 to cigar lighter
With ignition turned on,check for 12v at both locations stated by Digger84. Can't confidently tell you exact location of the cig relay but I would also trace and check the voltage there. I'm thinking it's under dash driver side since it's being powered by ignition switch.
Wattapunk is offline   Quote
Old 04-06-2016, 11:20 PM
Thread Starter
  #11
Jeeper
 
Zarranz's Avatar
 
Join Date: Jul 2012
Location: Cape Coral, FL
Posts: 36
Problem solved

Hope this helps others. Did all the troubleshooting suggested and came up with thsi solution. Two problems that develop at the same time are NOT necessarily related. I found the horn issue was a faulty connector at the horn itself. All fuses and relays OK I just had to fix the connector. The cigar lighter had power I found and the problem was the lighter socket itself. This was a quick cheap fix. Thanks all for the help

Zarranz is offline   Quote
Reply

Tags
electrical , horn , lighter

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 02:36 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.