2.5 random miss need help - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 06-18-2014, 12:07 PM
Thread Starter
  #1
Newb
 
Join Date: Jun 2014
Posts: 3
2.5 random miss need help

Okay I've done a lot of reading the past couple months trying to
Figure this out and haven't been able to pin point the problem if someone does know of another thread then you can just post the link and ill read it. This is my first post but have read on this forum for a couple
Years just try not to post if I don't have to... Anyways here's the problem I have a 99 TJ 2.5 and has no codes showing but has a random miss when under a load for awhile sometimes it takes 30 minutes for it to miss once sometimes less than a minute. I've changed wires plugs rotor cap ignition coil and TPS sensor. With 31s the jeep was still getting 17-19mpg I didn't think that was too bad of mileage. I've read up on it possibly being the crank position sensor but its not throwing any codes at all and from what I gathered it does throw a code normally for it. Also when it misses for a few times in a row sometimes the tach will spike up to 6k even though the engine isn't turning that much sometimes it bottoms out to 0 any help would be greatly appreciated love my Jeep and drive it everyday

__________________
1999 Jeep Wrangler: 2.5 5 speed 2.5 RE lift 33 12.50 15 Grabber AT2 tires
2001 Jeep Grand Cherokee: 4.7 545RFE 6.5" Iron Rock Offroad front and rear long arm lift 35 12.50 15 Baja MTZ tires
2005 Dodge 2500: 5.9 Cummins BHAF, straight pipe, and programmer
2000 SS Camaro: too much to list not enough to be finished
SlpSS is offline   Quote
Old 06-19-2014, 10:54 PM
Thread Starter
  #2
Newb
 
Join Date: Jun 2014
Posts: 3
Anyone? Please??

__________________
1999 Jeep Wrangler: 2.5 5 speed 2.5 RE lift 33 12.50 15 Grabber AT2 tires
2001 Jeep Grand Cherokee: 4.7 545RFE 6.5" Iron Rock Offroad front and rear long arm lift 35 12.50 15 Baja MTZ tires
2005 Dodge 2500: 5.9 Cummins BHAF, straight pipe, and programmer
2000 SS Camaro: too much to list not enough to be finished
SlpSS is offline   Quote
Old 06-19-2014, 11:03 PM   #3
Jeeper
 
Majnoon's Avatar
 
Join Date: Apr 2013
Location: Springfield Missouri
Posts: 3,163
I'm lost. Just a dumb idea. Are the plugs gapped properly? Did you change all this stuff to fix the problem? Or did it start after all the stuff was changed?
Majnoon is offline   Quote
Sponsored Links
Advertisement
 
Old 06-20-2014, 05:38 AM   #4
Jeeper
 
Join Date: May 2014
Posts: 71
CPS maybe? It's a pretty common issue on these.
thzpcs is offline   Quote
Old 06-20-2014, 07:04 AM
Thread Starter
  #5
Newb
 
Join Date: Jun 2014
Posts: 3
Plugs are gapped properly and I did it to fix the problem so unless I got faulty parts From the parts store then I don't think it is which is a possibility but when I checked the TPS it tested fine but got one anyways since I had read heat and vibrations could mess with them also. My plans this weekend are to change the CPS possibly a distributor, and disconnect everything check pins and re grease everything
__________________
1999 Jeep Wrangler: 2.5 5 speed 2.5 RE lift 33 12.50 15 Grabber AT2 tires
2001 Jeep Grand Cherokee: 4.7 545RFE 6.5" Iron Rock Offroad front and rear long arm lift 35 12.50 15 Baja MTZ tires
2005 Dodge 2500: 5.9 Cummins BHAF, straight pipe, and programmer
2000 SS Camaro: too much to list not enough to be finished
SlpSS is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 04:18 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.