2004 TJ rear locker light blinking with a twist.. - Jeep Wrangler Forum
Jeep Wrangler Forum

Go Back   Jeep Wrangler Forum > TJ Jeep Wrangler Forum > TJ Tech Forum

Join Wrangler Forum Today


Reply
 
Thread Tools

Please support our sponsors and let them know you heard about them on WranglerForum.com
Old 03-19-2016, 04:29 PM
Thread Starter
  #1
Jeeper
 
Join Date: Dec 2015
Posts: 47
2004 TJ rear locker light blinking with a twist..

So my 2004 Manual TJ Rubicon that is new to me and first rubicon keeps blinking that the rear locker isn't locked, FYI, I have the Terflex LCG pro kit that came installed when I bought it, both pumps were relocated and tucked behind to the rear lip where rear passangers put there feet(where your heels would go) on the undcarriage I checked it with a jack by picking up one tire and it is in fact locked, I tried securing the key in tight while locked and it didn't help as I have read this could be an issue, front locks fine. When I climb an obstacle like a small dirt hill it goes solid same thing happens when I reverse up a dirt hill at a steep incline, goes solid. Back down to flat the rear blinks. I turned off the key while locked and removed the key both kept blinking which I think is normal, when I climbed under the rig, the rear pump seems to be cycling on and off in 1.5 second intervals, nothing for the front....I've researched as much as possible and tried all the tricks I read and still no fix.
Airline seems in good shape along with the connections on both ends and seems to be holding pressure. I tapped on the electronic connectors and made sure connections were snug as I read this can also fix this issue. Tried holding in the key, no dice either. Any help would be greatly appreciated

fishnwheel is offline   Quote
Old 03-19-2016, 09:24 PM   #2
Jeeper
 
gnater76's Avatar
 
Join Date: Dec 2013
Posts: 650
That means you have a leak between the pump and the tang on the diff. Must be small for the pressure to build enough to lock. That's why you hear the pump cycling on/off. If you can get to the pumps and diff connections, spray some soapy water around, look for bubbles. Also check the line, when rerouted it may be rubbing somewhere and developed a pinhole leak.
__________________
-Nat

2006 Rubi LJ, 6 spd. OME 2.5" HD spring lift, 1.25" JKS BL, MML, discos, front & rear track bars, ZJ steering links, lots of LEDs, Shittybuilt front & rear bumpers, Novak transfer case cable.....blah blah blah
gnater76 is offline   Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






All times are GMT -5. The time now is 03:06 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.1
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.

Jeep®, Wrangler, Liberty, Wagoneer, Cherokee, Gladiator, Mopar and Grand Cherokee are copyrighted and trademarked to FCA US LLC.
Wranglerforum.com is not in any way associated with FCA US LLC.